If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

It is possible to open a new tab without showing all tabs in the same window.

RESOLVED DUPLICATE of bug 243893

Status

()

Firefox
Tabbed Browser
RESOLVED DUPLICATE of bug 243893
13 years ago
12 years ago

People

(Reporter: toohard4ur, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3

This becomes a problem especially when clicking on a web link that creates a tab
in a new window without any navigation information.  If I cause another tab to
open in the same window, I have no way to get back to the previous tab.  Mouse
right click doesn't proved a "go back" function.  When try to close the browser
window, It tells me that I am about to close the, say, 3 tabs.  This is cool. 
Yet  I have no way to access the other two tabs.  This is not cool.

Reproducible: Always
(Reporter)

Comment 1

13 years ago
Context sensitive menu should, at least, have a feature to close the current
tab.  This way, at least, I can pop the stack, sorta speak
*** Bug 292249 has been marked as a duplicate of this bug. ***

Comment 3

13 years ago
Sound like a dup of bug 182185 to me.

Comment 4

13 years ago
(In reply to comment #3)
> Sound like a dup of bug 182185 to me.

No, they're kinda related but they're not the same issue.  This bug is talking
about being unable to access new tabs in chromeless (if that's the term)
windows.  The other one, at least from what I read from bug 182185 comment 6,
talks about external links opening in chromeless windows.

Comment 5

13 years ago
Try <ctrl>-1, <ctrl>-2, <ctrl>-3 to select tabs, or <ctrl>-<tab> and
<ctrl>-<shift>-<tab> to cycle forwards and backwards through the tabs.
(Reporter)

Comment 6

13 years ago
(In reply to comment #5)
> Try <ctrl>-1, <ctrl>-2, <ctrl>-3 to select tabs, or <ctrl>-<tab> and
> <ctrl>-<shift>-<tab> to cycle forwards and backwards through the tabs.

GOOD (undocumented?) work around.  But how would one close one of these tabs?

Comment 7

13 years ago
Reproducable in Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8)
Gecko/20050511 Firefox/1.0.4 and the same version on
(1.04) on Fedora Core 3 Linux.

When there is no File-menu-toolbar or a tab-toolbar in a tabbed-window (created
by the server, say), there is no mouse-only way to close it.

To reproduce: 

1. http://newyork.mets.mlb.com/NASApp/mlb/index.jsp?c_id=nym

2. Vote and click on the poll: "Which is Chris Woodward's best position?" or
another poll if this is replaced by the time that you read this.

3. Click on "Discuss this poll".  This yields a second tabbed window without a
File menu dropdown capability (no navigational toolbars).

Note that right-clicking in the poll-discussion tabbed-window does not present a
"close tab" option.  The only way to close this window without closing every
tabbbed window in the set is to know the control-character sequence, Ctrl-w,
something most Baseball fans are not likely to know.

Proposed solution: Add a "Close Tab" to the right-click drop-down menu of a
focused window of this type (no tab-function aids).

Everyone loves a free lunch: How about some more tab functionality like "Close
All Tabs", "New Tab", etc. to the same right-click drop-down menu to cover this
situation fully?
(Reporter)

Comment 8

13 years ago
work around:  ctrl-w closes current tab.  See comment #5 for how to run through
the tabs.

As far as free lunches, how about a context sensitive menu that allows for the
display of menu/tool bars?

Comment 9

12 years ago
This issue may be solved by Bug 143866.  Test with current build and see if it's
still an issue.

Comment 10

12 years ago

*** This bug has been marked as a duplicate of 243893 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.