All users were logged out of Bugzilla on October 13th, 2018

time is 6 hours shifted when linked to an open-xchange server

RESOLVED INVALID

Status

RESOLVED INVALID
14 years ago
14 years ago

People

(Reporter: jmreymond, Assigned: shaver)

Tracking

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.7.6) Gecko/20050405 Firefox/1.0 (Ubuntu package 1.0.2)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.7.6) Gecko/20050405 Firefox/1.0 (Ubuntu package 1.0.2)

When connecting mozilla calendar to a remote open-xchange server, all the time
are 6 hours shifted (8H00 AM on server open-xchange, 14h on mozilla calendar)

Reproducible: Always

Steps to Reproduce:
1.create a new calendar
2.remote path: http://jmax.dyndns.org/servlet/webdav.ical
3.user testcal, passwd bogus
4. load remote calendar
Actual Results:  
for 29.04.05, the two appointemants at 8:00AM and 14H00AM are 6 hours shifted


mail from  open-xware developers:

Hi,

Open-Xchange sends the dates in the format yyyyMMddTHHmmssZ

like this example: 20050317T095619Z

Times are expressed in UTC with a special UTC designator ("Z"),
which works very well for several other clients. So i guess
that the mozilla calendar contains a bug.

Comment 1

14 years ago
This looks closely related to bug 230371 and/or bug 272411.  I'd especially
suggest bug 230371 comment #3.  While neither is phrased very clearly, if you
feel that this is a duplicate of one of those reports, I'd ask you to please
resolve it as such.
(Reporter)

Comment 2

14 years ago
bug was in Open-Xchange. Timezone was not set correctly
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.