Opening a link in a new tab causes the current page to jump to the top if no other tabs are open

RESOLVED FIXED

Status

()

--
major
RESOLVED FIXED
14 years ago
14 years ago

People

(Reporter: jcginn, Assigned: roc)

Tracking

({regression})

Trunk
x86
All
regression
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.8b2 +

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
Opening a link in a new tab, when no other tabs are open, will cause the site
loaded in the original tab to jump to the top of the page. This is especially
noticeable when tabs are set to load in the background. The reverse is also true
- if two tabs are open, closing one of the tabs will cause the other tab to
scroll to the top.

Steps to reproduce:

1) With no other tabs open, visit a site like Mozillazine.
2) Scroll down the page some.
3) Middle click a link to open it in a new tab.

The tab containing the initial website (Mozillazine in the example) will scroll
back to the top of the page. 

I think this might have been caused by the checkin for Bug 240276.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050428
Firefox/1.0+
Depends on: 292286
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050429
Firefox/1.0+

confirming
->Major (because it partially breaks naviagation)

this also can been seen in Chatzilla randomly scrolling to the top
Severity: normal → major

Comment 2

14 years ago
I can confirm this with SeaMonkey Build 2005042822 too. 

So I think this one is a Core-Layout-Bug. Probably someone with
editbug-Privileges can change the Product and Component fields. 
(Reporter)

Updated

14 years ago
Assignee: nobody → roc
Component: Tabbed Browser → Tabbed Browser
Product: Firefox → Core
(Reporter)

Updated

14 years ago
Component: Tabbed Browser → Layout

Comment 3

14 years ago
Confirming on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2)
Gecko/20050428 Firefox/1.0+ (without using tabs)

BTW it seems page scrolling is a bit stuttering now, is it only me or a
byproduct of this bug?

(In reply to comment #3)
> BTW it seems page scrolling is a bit stuttering now, is it only me or a
> byproduct of this bug?
I noticed some drag too

Comment 5

14 years ago
same thing in gtk2+xft, must be related to CZ opening everything anchored to the top
OS: Windows XP → All

Comment 6

14 years ago
A similar issue, I think probably related (or at least likely caused by bug
240270): when a long page is loading it jumps to the top of the page at each
reflow. For example, search in Bugzilla for the phrase ‘tab’, and you can’t
scroll down.

~Grauw
Flags: blocking1.8b2?
(Reporter)

Updated

14 years ago
Flags: blocking-aviary1.1?

Comment 7

14 years ago
Is this fixed by bug 292286?

Comment 9

14 years ago
I can verify that this is fixed on Mac OS X, using an Atlantia build that
includes the fix for bug 292286.  Looks like the next Beast build will have it
too...

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050501
Firefox/1.0+

Comment 10

14 years ago
(In reply to comment #9)
> I can verify that this is fixed on Mac OS X, using an Atlantia build that
> includes the fix for bug 292286.  Looks like the next Beast build will have it
> too...
> 
> Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050501
> Firefox/1.0+

Same here, on Windows 2000, using the latest beast build.
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050501
Firefox/1.0+
(Reporter)

Comment 11

14 years ago
Resolving Fixed.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Updated

14 years ago
Flags: blocking-aviary1.1?
You need to log in before you can comment on or make changes to this bug.