Lines are wrapped when editing a draft

RESOLVED DUPLICATE of bug 155622

Status

SeaMonkey
MailNews: Message Display
--
minor
RESOLVED DUPLICATE of bug 155622
13 years ago
13 years ago

People

(Reporter: Richard Körber, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.7.6) Gecko/20050328 Fedora/1.7.6-1.2.5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.7.6) Gecko/20050328 Fedora/1.7.6-1.2.5

When editing a draft, Mozilla inserts line feeds instead of just soft wrapping
the mail body. This is not immediately visible when editing a draft. Anyhow,
when text is added into an existing paragraph, you will see that line feeds have
been automatically inserted.

Reproducible: Always

Steps to Reproduce:
1. Create a new mail.

2. Write a text that is several lines long, and do not use the return key at the
end of a line. For example:

The quick fox jumps over the
lazy dog.

For the sake of this example, let's pretend that Mozilla soft wrapped the line
after the "the".

3. Save this mail as draft.

4. Go to the draft folder and open the draft for editing.

5. Now place the cursor into a paragraph and add more words. For this example,
let's add the word "brown" at the right place.
Actual Results:  
The given example would now read:

The quick brown fox jumps
over the
lazy dog.

Mozilla soft wraps the line after "jumps", but there is a line feed after "the"
which must be removed manually.

Expected Results:  
The given example should read:

The quick brown fox jumps
over the lazy dog.

With a soft wrap just after the "jumps".

Comment 1

13 years ago
dupe of 'Wrapping information lost on "Edit as new" (including templates), "Edit
draft" -- RFC 2646 format=flowed'

*** This bug has been marked as a duplicate of 155622 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Version: unspecified → Trunk
You need to log in before you can comment on or make changes to this bug.