Toolbar Display customization does not display properly in Sunbird 0.2

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
14 years ago
13 years ago

People

(Reporter: sumguy231, Assigned: mostafah)

Tracking

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a5) Gecko/20050203 Mozilla Sunbird/0.2

When running Sunbird 0.2, when I enter the toolbar customization by right
clicking on the toolbar and selecting customize, the customization field
displays with a glitched portion around it, which displays the last portion of
the screen shown.
A screenshot is provided at the URL I gave.

Reproducible: Always

Steps to Reproduce:
1. Open Mozilla Sunbird
2. Right Click on main toolbar
3. Click Customize

Actual Results:  
The display glitch appeared.

Expected Results:  
The field should display as shown in the screenshot at
http://www.mozilla.org/projects/calendar/images/sunbird-customize-toolbar.png

No theme was used, no unusual settings changed.
(Reporter)

Comment 1

14 years ago
Created attachment 182226 [details]
Screenshot of Glitch

Comment 2

14 years ago
Andrew,
   This is definitely behavior I didn't expect to see, but it likely a variant
of bug 274352.  Can you say whether or not the toolbar you are seeing is
functional?  For instance, does clicking the Minimize, Maximize, Close button do
anything?  Can the window me moved around the screen by dragging the title bar?
 Also, can you resize the window?
(Reporter)

Comment 3

14 years ago
(In reply to comment #2)
> Andrew,
>    This is definitely behavior I didn't expect to see, but it likely a variant
> of bug 274352.  Can you say whether or not the toolbar you are seeing is
> functional?  For instance, does clicking the Minimize, Maximize, Close button do
> anything?  Can the window me moved around the screen by dragging the title bar?
>  Also, can you resize the window?

Sorry it took me a little bit to reply, I was away. The customization toolbar
itself still works, however, the glitched are around it which sometimes displays
as a window or simply a glitched field are not functional. (Minimizing,
Maximizing, Closing does nothing, and the window is non-functional) Thank you
for your time and extremely quick response! I was amazed!

Hope to hear from you soon,
Andy C.

Comment 4

14 years ago
(In reply to comment #3)
 The customization toolbar
> itself still works, however, the glitched are around it which sometimes displays
> as a window or simply a glitched field

Andrew,
    Just for clarification, are you saying this error shows itself in 2
different forms or is "as a window" describing proper functionality?  If it's 2
forms, could you also supply a screenshot of the second way the error displays?
 It would also be useful if you could try to track down actions that determine
which way the error will appear.
(Reporter)

Comment 5

14 years ago
(In reply to comment #4)

> Andrew,
>     Just for clarification, are you saying this error shows itself in 2
> different forms or is "as a window" describing proper functionality?  If it's 2
> forms, could you also supply a screenshot of the second way the error displays?
>  It would also be useful if you could try to track down actions that determine
> which way the error will appear.
> 

Sorry I wasn't more clear. I will add a second screenshot to this page that may
add clarification. Please look at it. The orange you see is my desktop. What I
am trying to get across is that the glitched field displays a non-functional
window when the toolbar is first opened, and when I switch to a different
window, then switch back, the glitched field displays what was on the screen
last. I hope this was clear enough, and I hope to hear back on this.
(Reporter)

Comment 6

14 years ago
Created attachment 182345 [details]
A second screenshot of the glitch in question.

The orange is part of my desktop.

Comment 7

14 years ago
Andrew,
   After opening (and then closing) the customize toolbar window, are there any
errors/warnings displayed in the JavaScript Console (in the Tools menu)?

Also, note, I'm just helping to pin down/triage this bug.  I would not expect a
speedy resolution of it.  As you may know, Sunbird/Calendar is getting a
back-end rewrite, which is a very large task and is the priority right now. 
Something like this probably won't be fixed for awhile, since basic
functionality is not impaired.
(Reporter)

Comment 8

14 years ago
(In reply to comment #7)
> Andrew,
>    After opening (and then closing) the customize toolbar window, are there any
> errors/warnings displayed in the JavaScript Console (in the Tools menu)?
> 
> Also, note, I'm just helping to pin down/triage this bug.  I would not expect a
> speedy resolution of it.  As you may know, Sunbird/Calendar is getting a
> back-end rewrite, which is a very large task and is the priority right now. 
> Something like this probably won't be fixed for awhile, since basic
> functionality is not impaired.

No, the JavaScript Console displays nothing afterwards.

Comment 9

14 years ago
Andrew,
   As you may know, a testing build of Sunbird was released recently.  While it
isn't stable enough for daily use, I did check to see if your bug (or the
related bug 274352) was still there, and it appears that it has been solved. 
This bug should be left open until the next stable version comes out and you can
confirm that the bug has disappeared.  I just wanted to let you know to expect
the fix.

Comment 10

13 years ago
Works for me, I've seen it on older builds though, I guess it's been fixed.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050807 Mozilla
Sunbird/0.2+

Comment 11

13 years ago
Marking as WFM since there's no specific patch to point to.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME

Updated

13 years ago
QA Contact: gurganbl → sunbird
You need to log in before you can comment on or make changes to this bug.