Closed Bug 292429 Opened 16 years ago Closed 5 years ago

Tamil unicode is not displayed properly

Categories

(Core :: Internationalization, enhancement)

x86
Windows XP
enhancement
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: jaganak, Assigned: jshin1987)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3

Tamil Unicode fonts (Indic Script) eg., அண்பர்களே,
நான் நலம். நீங்களும் நலம்தானே? This is not how tamil is written.
Note: Tamil unicode is displayed properly on IE.

Reproducible: Always

Steps to Reproduce:
1.Type texts in tamil eg, ளே
2.Do the same thing in IE.(after installing indic scripts in xp control panel
'regional settings' and adding tamil as additional language)
3.U will find the difference

Actual Results:  
Single characters that r to be typed in 2 key strokes r displayed as 2 characters.

Expected Results:  
It must have redrawn the first typed base character on the 2nd key stroke,
instead of an additional character.
Not disability access.

Reporter, can you show us an example ?
Component: Disability Access → General
QA Contact: disability.access → general
A testing page I found:
http://www.alanwood.net/unicode/tamil.html
Probably a duplicate of bug 140013, although Jungshik Shin claims that it should
work on Windows XP (bug 140013 comment 23 and below).
Same behaviour is seen for Hindi unicode fonts
Assignee: nobody → jshin1987
Component: General → Internationalization
Product: Firefox → Core
Version: unspecified → Trunk
QA Contact: general → amyy
Similar problem exists in Devanagari based languages. 
See www.pragatischool.org/newerindex.php for example of this.
Lays out correctly on my machine in IE 6.0 (Windows XP, US install,
no regional support turned on) Switch page to 'Hindi' (second item in
list if you don't understand language).
Problem is probably due to incorrectly assuming that sum of glyph widths
is layout width. anne@pragatischool.org
QA Contact: amyy → i18n
I tested on the latest Nightly 46, it works fine.  If not fixed, please attach the screenshot by the latest Firefox.
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.