Need better visual design for mail envelope icons

VERIFIED FIXED in M18

Status

SeaMonkey
MailNews: Message Display
P3
trivial
VERIFIED FIXED
18 years ago
13 years ago

People

(Reporter: Phil Peterson, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3-])

Attachments

(3 attachments)

(Reporter)

Description

18 years ago
The more I see these icons (attachments and add-to-address-book) the less I like
them. I think they're not sufficiently visually distinct. Maybe something more
like the toolbar icons would be more helpful.

I'm also wondering whether we should try to integrate mscott's menu with the
icon. Just a thought. The UI design of widgets in the envelope area just isn't
holding together, IMO.

Comment 1

18 years ago
Reassign to Shuang since she is creating the icons.

What do you mean by "integrate mscott's menu with the icon"?
Assignee: jglick → shuang
(Reporter)

Comment 2

18 years ago
> What do you mean by "integrate mscott's menu with the icon"?

I mean that when you click on a recipient link, you get a menu with a couple of 
things you can do with that recipient. If we think that's a good idea, why 
wouldn't we make that available on the Add To Address Book button? Alternately, 
if we think it's redundant, would we remove the Add To Address Book button? 

Comment 3

18 years ago
It needs a tooltip, too.
(Reporter)

Comment 4

18 years ago
*** Bug 30727 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 5

18 years ago
Another thing I think is important: the appearance of the attachment icon should 
be noticeably different when the message contains attachments, vs. when it 
doesn't.
(Assignee)

Comment 6

18 years ago
Hmm but we don't show an attachment icon if there aren't any attachments in the
message. So why would it need to look different? =)

Comment 7

18 years ago
mscott is correct.  Like 4.x, no attachment icon is shown if there are no 
attachments.
(Reporter)

Comment 8

18 years ago
Ok, how about this then. Could the attachment icon be more different than the 
message envelope? Could we use the dark blue/light blue/white color scheme like 
the toolbar buttons?

Comment 9

18 years ago
Leave it till after beta 2: I don't have anyone can work on this now, and I will 
be on sabbatical 03/20-04/28.
Severity: normal → trivial
Target Milestone: M17

Updated

18 years ago
Keywords: ui

Comment 10

18 years ago
Some potential alternate attachment icons for ideas/thought:

http://gooey/client/5.0/specs/mail/Misc/Icons/attachm1.gif
http://gooey/client/5.0/specs/mail/Misc/Icons/attachm2.gif
http://gooey/client/5.0/specs/mail/Misc/Icons/attachm3.gif
http://gooey/client/5.0/specs/mail/Misc/Icons/attachm4.gif
(Reporter)

Comment 11

18 years ago
Thanks for looking into this Jennifer. Attachm2.gif and attachm3.gif are zero bytes.

Comment 12

18 years ago
Fixed.  If folks have general ideas for what they would like to see, this will 
help once Shuang returns or our new graphic artist starts. (May 1).

Comment 13

18 years ago
Paul, can you reassign this for us?  Thx, Steve
Assignee: shuang → hangas

Comment 14

18 years ago
Sending to Jennifer.
Assignee: hangas → jglick

Comment 15

18 years ago
OK, Jen's attempt at some better icons:

Add to AB:
http://gooey/client/5.0/specs/mail/Misc/Icons/AddAB1.gif  (16x16)
http://gooey/client/5.0/specs/mail/Misc/Icons/AddAB2.gif   (17w x 16h)
http://gooey/client/5.0/specs/mail/Misc/Icons/AddAB3.gif  (16x16)
http://gooey/client/5.0/specs/mail/Misc/Icons/AddAB2.gif  (16x16)

I like #2 but it is 17 x 16.  Is that ok?  If not #1 or #3.  

Attachment:
http://gooey/client/5.0/specs/mail/Misc/Icons/attachm1.gif
http://gooey/client/5.0/specs/mail/Misc/Icons/attachm2.gif
http://gooey/client/5.0/specs/mail/Misc/Icons/attachm3.gif
http://gooey/client/5.0/specs/mail/Misc/Icons/attachm4.gif

I like #1.

Phil, are any of these acceptable?

In addition, adding menu functionality to to AB button is a good idea. We could 
have a dropdown menu when the AB button is clicked:  

"Add Sender to AB"
"Add all Recipients to AB"  
(Reporter)

Comment 16

18 years ago
Not sure if I have an opinion based on the one-color icons shown here. What 
would they look like in the envelope area? Would we use the blue toolbar button 
color? Or would we use the gray envelope area color? As I said in my original 
comments in the bug, I think some visual distinction (or maybe contrast is a 
better word) would help.

Comment 17

18 years ago
Created attachment 9837 [details]
Mail1b.gif

Comment 18

18 years ago
Created attachment 9838 [details]
Mail1.gif

Comment 19

18 years ago
How is this?  See attachments.  I like Mail1b.gif better.
(Reporter)

Comment 20

18 years ago
Mail1b.gif works for me

Comment 21

18 years ago
Created attachment 9853 [details]
Mail1c.gif

Comment 22

18 years ago
At the Mail Issues meeting today we discussed the Mail Evelope area. Team liked 
the 'Add to AB" icon in Mail1b.gif but wanted the swiggles removed. Mail1c.gif 
show the icon revised.  If there are no objections, this is what we'll use.

Icons for Add to AB and Attachment are here:
http://gooey/client/5.0/specs/mail/Misc/Icons/addtoab.gif
http://gooey/client/5.0/specs/mail/Misc/Icons/attachment.gif

Reassign to mscott to implement.

Meeting notes can be found here:
http://gooey/client/5.0/specs/mail/messenger/MeetingNotes/Notes_Envelope_6_8_00.
html
Assignee: jglick → mscott

Comment 23

18 years ago
moving to M18 and nominating for beta3
Keywords: nsbeta3
Target Milestone: M17 → M18

Updated

18 years ago
Keywords: mail6

Comment 24

17 years ago
mail triage marking [nsbeta3-]
Whiteboard: [nsbeta3-]
(Assignee)

Comment 25

17 years ago
this is just a new icon which jennifer already gave us. we'll get this in there
for beta3.

Comment 26

17 years ago
Yes, this bug has a mail6 keyword so if the fix is easy and trivial, we can 
change to a + to fix.

Updated

17 years ago
Blocks: 29303

Comment 27

17 years ago
This bug has been fixed (by me!) with check-ins for Modern and Classic skin 
cleanup bugs (46423 and 46519).

Attachment icon updated for both Modern and Classic skins.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
(Assignee)

Comment 28

17 years ago
Awesome!! Congrats on your first set of mozilla checkins!

Comment 29

17 years ago
Thank you!  This engineering stuff is tough!  :-)
VERIFIED to get off mscott's radar.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.