mozilla (browser) follows accesskey but it should type the char I want to write into a form

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
14 years ago
4 months ago

People

(Reporter: eMailBugzilla.10.gaensler, Assigned: aaronlev)

Tracking

({access})

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

()

User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8b2) Gecko/20050429
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8b2) Gecko/20050429

Mozilla follows the link while typing [Alt] + [0]-[1]-[8]-[7] on the seperate
numblock on my keyboard because accesskey "7" has been specified.

My (expected) solution: Mozilla follows accesskeys if the [Alt]-key is released
on the keyboard. If more than one key is pressed in the time the [Alt]-key is
pressed down, Mozilla should not try to interpret this as an "accdess-key press".

PS: As far as I remember this problem hasn't occured in Mozilla 1.7.x (1.7.6(?))

Reproducible: Always

Steps to Reproduce:
1. Go to example page linked above and follow steps there

Actual Results:  
Mozilla follows example-link to google.com

Expected Results:  
type the char that I wanted to be written into the form/input

Bug reproduced using Mozilla (Browser) 1.8b2 20050429 with the modern-theme,
english language, Webdeveloper (webdeveloper.mozdev.org) installed
For copy paste use:
»

And I'm not sure if this is in Mozilla Suite, but in firefox you can go to
about:config and set accessibility.accesskeycausesactivation to false.  Since
you seem to not want to use accesskeys anyway, that should work out fine.

This is only some advice that I can offer now, as I'm not a Seamonkey dev, but
it should tide you over.
(In reply to comment #1)
> For copy paste use:
> »
Thank you. That is the workaround I use if I have to type it. Open an editor,
write it there and copy it into the webpage.

> about:config and set accessibility.accesskeycausesactivation to false.
Yes, this can also be done in Mozilla Suite.
> Since you seem to not want to use accesskeys anyway, that should work out fine.
Sorry, I think you missunderstood me. I want to use accesskeys, but I also want
to be able to write chars as written above. I use accesskeys more often than
typing such chars and so I have them turned on.

But thank you for your comment.

*** Bug 293900 has been marked as a duplicate of this bug. ***
Assignee: general → aaronleventhal
Status: UNCONFIRMED → NEW
Component: General → Keyboard: Navigation
Ever confirmed: true
Product: Mozilla Application Suite → Core
QA Contact: general → keyboard.navigation
Version: unspecified → Trunk
I just wanted to push this. The problem is still present.

The workaround of comment #1 doesn't work in SeaMonkey, because the focus of the textarea is lost and so the char is "caught" by the "live search" of the browser.

I found a very simple solution: Disable accesskeys for the numpad, because typing in special chars with [alt]+Num only works with the numpad.
OS: Windows 98 → Windows XP
Can't reproduce on mac

Build identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.2pre) Gecko/2008080604 Firefox/3.0.2pre
This was fixed with the bug that added the "shift" key to all access keys. On the example page, the access key is now Alt+Shift+7. Closing as WFM.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → WORKSFORME
Component: Keyboard: Navigation → User events and focus handling
You need to log in before you can comment on or make changes to this bug.