thunderbird (several versions) freezes with 100%cpu with duplicate message-id message id ids

RESOLVED WORKSFORME

Status

Thunderbird
General
--
critical
RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: Meat Popsicle, Assigned: Bienvenu)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3
Build Identifier: Debian thunderbird: version 1.0.2 (20050331) and others (recent)

thunderbird freezes with 100% cpu load when a local folder contains several
messages with the same message-id but different contents. The bug may be
triggered by 10-15 messages with the same id in a folder that contains 100+
other messages.

Reproducible: Always

Steps to Reproduce:
1. create a set of messages of which 10 have the same id (by editing them)
2. feed messages to test email account via MTA (f.ex. using formail)
3. open thunderbird on that account and get all the messages, save them to a
dedicated folder (assume they come from a mailing list)
4. close and reopen thunderbird. The bug should appear (at the latest when
opening the relevant mailbox folder)

Actual Results:  
100% cpu load and no reaction from thunderbird

problem was reported by several users on different platforms. It was caused by a
broken email system that sent messages with the same ids to a mailing list over
about two weeks.

Expected Results:  
normal operation (open thunderbird)
(Assignee)

Comment 1

13 years ago
can you attach or e-mail me such a folder with some sample messages? thx!
Assignee: mscott → bienvenu
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: thunderbird (several versions) freezes with 100%cpu with duplicate message-id message id ids → thunderbird (several versions) freezes with 100%cpu with duplicate message-id message id ids
(Assignee)

Comment 2

13 years ago
Thx for the sample messages. This works fine with trunk builds. The fix will be
in 1.1.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.