SVG : Firefox does not reverse properly to the user space unit in text tags

RESOLVED DUPLICATE of bug 286101

Status

()

Core
SVG
RESOLVED DUPLICATE of bug 286101
13 years ago
13 years ago

People

(Reporter: Paco, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050426 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050426 Firefox/1.0+ + SVG

Please compare :
#1 
http://www.euro-fam.org/eurunion/documents/Codecision.psvg?LG=EN&LJ=FR
And :
#2 
http://www.euro-fam.org/eurunion/documents/Codecision.svg?LG=EN&LJ=FR

#1 does not display properly using Firefox (it does using ASVG)
#2 does display correctly in both viewers.

Now the only difference (apart a slight correction of the root element width,
height and viewbox size to better fit a brwoser window) is the following :
- in #1 : all font-size expressed in pixels, but implicitly (as in : <text
style="font-size:423">) ;
- in #2 : all font-size expressed in mm (as in : <text style="font-size:90mm">)

So apparently Firefox has a bug there, not properly setting the font size in
pixels when the unit is not explicit.

Proof : if  explicitly adding "px" unit in #1 (<text style="font-size:423px">
instead of <text style="font-size:423">), Firefox display the page correctly.

As far as I understand, Firefox should refer to the user space unit when no unit
is specified : 
" Lengths in SVG can be specified as: (if no unit identifier is provided) values
in user space -- for example, "15" " (SVG 1.1 specification).

The conclusion is that Adobe has it right : the viewport des not specify the
user spac unit, thus it reverse to pixels, thus font-size with no unit
indentifier reverse to pixels.
Firefox should follow the same rule, IMHO.

Reproducible: Always

Steps to Reproduce:
1. Open the
http://www.euro-fam.org/eurunion/documents/Codecision.psvg?LG=EN&LJ=FR page


Actual Results:  
2. text does display ata ridiculous size.

Expected Results:  
Should have display like that :
http://www.euro-fam.org/eurunion/documents/Codecision.svg?LG=EN&LJ=FR

See comment above
Assignee: nobody → general
Component: General → SVG
Product: Firefox → Core
QA Contact: general → ian
Version: unspecified → Trunk
This is invalid according to the CSS spec.

*** This bug has been marked as a duplicate of 286101 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.