Local browsing at top level is impossible

VERIFIED FIXED in M15

Status

()

Core
Networking
P3
normal
VERIFIED FIXED
19 years ago
19 years ago

People

(Reporter: Henrik Gemal, Assigned: Chris Waterson)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+]w/b minux on 03/10)

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
It's impossible to enter:
file:///c|/
in the Location field and browse at the local file systems top level.

It's however possible to do:
file:///c|/temp

to browser sub directories!

BUILD: 2000022408

Comment 1

19 years ago
=> valeski
Assignee: gagan → valeski
Target Milestone: M15

Comment 2

19 years ago
sounds odd.
Assignee: valeski → waterson
(Reporter)

Comment 3

19 years ago
I think this is a *big* bug!
Whiteboard: PDT
(Assignee)

Comment 4

19 years ago
this is what gemal *meant* to do, I think.
Keywords: beta1
Whiteboard: PDT

Comment 5

19 years ago
Putting on PDT+ for beta1. Please fix by 03/10
Whiteboard: [PDT+]w/b minux on 03/10
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 6

19 years ago
dougt: it turns out this is a problem with nsLocalFileWin::ResolveAndStat(). 
Specifcally,

http://lxr.mozilla.org/mozilla/source/xpcom/io/nsLocalFileWin.cpp#511

The workingFilePath == "c:", and passing this to PR_GetFileInfo64() barfs. What 
we want to pass is "c:\".

Should I just patch the code around line 511 to check if we've got only a root 
directory, and then append a backslash? (It looks like there are assumptions in 
the rest of the file about there *not* being a backslash on the mWorkingPath.)
(Assignee)

Comment 7

19 years ago
Created attachment 6248 [details] [diff] [review]
proposed fix
(Assignee)

Comment 8

19 years ago
fix checked in, r=dveditz a=jevering
(Assignee)

Comment 9

19 years ago
fixed, even.
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 10

19 years ago
shrir can you verify this
QA Contact: tever → shrir
(Assignee)

Comment 11

19 years ago
*** Bug 27764 has been marked as a duplicate of this bug. ***

Comment 12

19 years ago
verified with today's windows commercial build (20000309m15)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.