Closed Bug 292506 Opened 15 years ago Closed 15 years ago

Extension Manager issues

Categories

(Toolkit :: Add-ons Manager, defect)

x86
All
defect
Not set

Tracking

()

RESOLVED INVALID

People

(Reporter: rstrong, Assigned: rstrong)

References

Details

Attachments

(6 obsolete files)

This is to cover a patch to fix a couple of regressions that bug 286034 introduced 
(e.g. bug 292248, bug 292362 and the EM part of bug 286525 (there is a patch in
bug 286525 that has already been approved that this patch relies on) as well as
a few other perhaps as yet undocumented regressions.
Attached patch patch in progress (obsolete) — Splinter Review
This patch is almost complete and requires the patches from bug 251026 and bug
251026
Assignee: nobody → moz_bugzilla
Status: NEW → ASSIGNED
Attached patch patch (obsolete) — Splinter Review
I suspect Ben will want to review this as well due to the number of changes.

This patch fixes:
* Theme uninstaller doesn't remove jar file - bug 251026 (the patch from this
bug is needed and is already r+=bsmedberg & sr+=darin)
* Extra jar files in the profile chrome dir - bug 286525 (the patch from this
bug is needed)
* Mac OS X crash when restarting Contetxt menu / widget enabling for the
extension and theme managers - bug 284515 
* After installing an extension or theme - bug 292362 (I believe this needs a
follow up bug)
* Unable to install themes - bug 291946
* Disabling / enabling an extension doesn't update the ui after restart
* Unable to uninstall a theme when it is in use
* When enabling / disbling extensions it can take multiple restarts to finish
* Installing a theme with a chrome.manifest more than once can break the ui.
* A theme installed via file drop creates an empty chrome.manifest
* Successful incompatible updates on install fail due to the file being deleted
- I am pretty sure this is bug 292248 and bug 292248 is WFM with this patch.

Other findings not fixed by this patch:
* Currently if you DnD more than one theme onto the Theme Manager one of the
theme's will not install and will remain as a download item in the Theme
Manager until it is installed again.
* On install (at least with a dropped in file) it tries to use the chrome url
for the icon and fails if it isn't installed (e.g. during an upgrade) or isn't
the same as the previous versions path to the icon.
* An update for the default theme is checked for on
https://addons.mozilla.org/update/VersionCheck.php and logs the
RDFItemUpdater:_parseV20UpdateInfo message in the js console twice
Attachment #182314 - Attachment is obsolete: true
Attachment #182369 - Flags: review?(mconnor)
Flags: blocking1.8b2?
Attached patch patch (obsolete) — Splinter Review
This includes a simple fix for a chrome upgrade eroor for the default theme on
first run of a new profile. This check could probably be done in a better
manner but I think this is sufficient for the review and can be changed now or
at a later time.
Attachment #182369 - Attachment is obsolete: true
Attachment #182394 - Flags: review?(mconnor)
Attached patch smaller patch (obsolete) — Splinter Review
This patch just covers the basic bugs and does not try to fix the worst of the
theme install issues, etc. - this way it is a lot easier to review and get this
set of smaller issues resolved.

Note: in each case where I changed the position of zipReader.close(); it was
due to finding in my testing cases where files were being held on to which
prevented rolling back files, etc.
Attachment #182394 - Attachment is obsolete: true
Attachment #182524 - Flags: review?(bugs)
Attachment #182524 - Attachment is obsolete: true
Attachment #182524 - Flags: review?(bugs)
Attached patch patch (obsolete) — Splinter Review
bah! I missed one very important change for incompatible updates in the last
diff
Any chance you can include a trivial patch for bug 291792 here? If you can,
please note so in that bug.
No longer blocks: 292248
No longer depends on: 251026, 286525
Attached patch patch (obsolete) — Splinter Review
This patch should resolve the majority of the remaining issues with the EM.
Attachment #182529 - Attachment is obsolete: true
Attachment #182916 - Flags: review?(benjamin)
*** Bug 293321 has been marked as a duplicate of this bug. ***
Comment on attachment 182916 [details] [diff] [review]
patch

Turns out that this doesn't work properly with the safe mode patch... I'll
re-work it.
Attachment #182916 - Attachment is obsolete: true
Attachment #182916 - Flags: review?(benjamin)
Flags: blocking1.8b3?
Flags: blocking1.8b2?
Flags: blocking1.8b2-
I opened this bug in an attempt to patch several regressions in one bug and the
code in this patch was used for the patches in bug 284515, bug 292362, and bug
291946. Since there is no longer any code in the patch needed, the items that
were to be addressed have either been fixed or have a patch in a separate bug
waiting review, and the set of regressions has lessened significantly I am
resolving this bug as INVALID.
No longer blocks: 284515
Status: ASSIGNED → RESOLVED
Closed: 15 years ago
Flags: blocking1.8b3?
Resolution: --- → INVALID
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.