Status

()

enhancement
RESOLVED WONTFIX
14 years ago
5 months ago

People

(Reporter: grin, Unassigned)

Tracking

({uiwanted})

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050421 Firefox/1.0.3 (Debian package 1.0.3-2)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050421 Firefox/1.0.3 (Debian package 1.0.3-2)

would be nice to have the possibility to split the tabs in multiple lines, to
make it possible to open, say, 100 tabs. 

Minimal size could be set, so surplus tabs [which would cause others to ge below
minimal size] would go in the next line. (Opera-like.)


Reproducible: Always

Steps to Reproduce:
1.open 40 tabs
2.try to read from the title what's in them :)
3.change the resolution to 1024x768 and try again

Actual Results:  
on eline contains all tabs, no title is visible

Expected Results:  
a dozen tab in 1st line with readable titles, other dozen in 2nd line, and so on.

I didn't find its original [searched hard], but I'd guess this is a duplicate,
so if you know the real one please link to it.

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 155325 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Unduping since this bug is in Firefox::TabbedBrowser, and a direct request for a single item which I could not find a duplicate of. The other bug is a more general bug that got morphed...

uiwanted: this could be a great improvement, and also follows os styles. My suggestion would be to keep the current behavior by default, but enable expanding the tabbar to make it multi-line. This is similar to the windows taskbar.
Flags: wanted-firefox3.6?
Keywords: uiwanted
OS: Linux → All
Hardware: x86 → All
Version: unspecified → Trunk
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: wanted-firefox3.6?
Duplicate of this bug: 693223
This bug will complicate the UI and break a lot of things. Instead Bug 597564 should be fixed.

Comment 6

8 years ago
Status: NEW → RESOLVED
Last Resolved: 14 years ago6 years ago
Resolution: --- → WONTFIX

Updated

5 months ago
Duplicate of this bug: 1468427
You need to log in before you can comment on or make changes to this bug.