Closed Bug 292600 Opened 16 years ago Closed 16 years ago

login incorrect error, when accessing an ftp with anonymous user and a constant password

Categories

(Core :: Networking: FTP, defect)

1.7 Branch
x86
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 266835

People

(Reporter: algpela, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 Gecko/20020604
Build Identifier: Mozilla/5.0 Gecko/20020604

On an ftp site, where an anonymous user has got a normal password, firefox gives
"530 Login or Password Incorrect" error, if accessed in
ftp://anonymous:password@host style. And I didn't find any other way to get
firefox ask for a password, when logging in with an anonymous user.

Reproducible: Always

Steps to Reproduce:
1. Open firefox
2. Type in url ftp://anonymous:password@host
3.

Actual Results:  
"530 Login or Password Incorrect" error

Expected Results:  
The browser should have shown the contents of the site.
Why do you don't use "ftp://anonymous@host" ?
(In reply to comment #1)
> Why do you don't use "ftp://anonymous@host" ?

Because I need to enter a specific password for user anonymous. If I use
ftp//anonymous@host, I'm not asked for a password.
In the future, please let us know which version of Firefox you're using.

Assuming you're using a 1.0.x version, I suppose this is expected behavior. 
This bug was fixed on the trunk back in November.  Deer Park Alpha 1, or a
recent Mozilla 1.8x version would have the bug fix in it.

*** This bug has been marked as a duplicate of 266835 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Component: General → Networking: FTP
Product: Firefox → Core
Resolution: --- → DUPLICATE
Version: unspecified → 1.7 Branch
You need to log in before you can comment on or make changes to this bug.