If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

When replying to mail from real name "Helena Göransson" two To: fields are displayed

RESOLVED DUPLICATE of bug 254519

Status

Thunderbird
Message Compose Window
RESOLVED DUPLICATE of bug 254519
13 years ago
13 years ago

People

(Reporter: johannes, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b) Gecko/20050217
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b) Gecko/20050217

I get mail from Helena Göransson <helena.goransson.x@domain.com>. When replying,
two To: fields are displayed in the Compose window, one To: 'Göransson' and one
To: 'Helena <helena.goransson.x@domain.com>'. 

If I view the message header in my webmail, Helena's name is written as 

'=?iso-8859-1?Q?G=F6ransson=2C_Helena?='

In Mozilla, the from field is simply 'Helena <helena.goransson.x@domain.com>'. 

Also, under Content-Type, it sais 'text/plain;	charset="iso-8859-1"' (i.e. there
seems to be a tab character btween 'plain;' and 'charset').

Her mail is X-MimeOLE: Produced By Microsoft Exchange V6.5.7226.0

Reproducible: Always

Steps to Reproduce:
1. Get mail from someone named Helena Göransson, using iso-8859-1 character
encoding with malformed Content-Type field (hypothesis)
2. Hit reply

Actual Results:  
Reply is directed to two addresses.

Expected Results:  
Reply is directed only to one address.
(Reporter)

Comment 1

13 years ago
Saw now that the name is not accepted as I recieve it. Proper last name for
Helena should be Göransson, i.e. second character is an o with two dots over it.

Comment 2

13 years ago

*** This bug has been marked as a duplicate of 254519 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.