doesn't recognize correct ended textarea tags

RESOLVED DUPLICATE of bug 181996

Status

()

--
minor
RESOLVED DUPLICATE of bug 181996
14 years ago
10 years ago

People

(Reporter: cipherz, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041001 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041001 Firefox/0.10.1

<textarea ... /> is not recognized as an ended textarea tag and the following
html code is put into the textarea.

However <textarea ..></textarea> is recognized as an ended textarea tag.

Reproducible: Always

Steps to Reproduce:
1. Create html page that contains <form ..> <textarea .. /></form>..
2. Open the page in firefox
3. Se the bug (the stuff after the textarea tag in the table tag)

Actual Results:  
You see a textarea with some html code in it.

Expected Results:  
You should see an empty textarea, since the <textarea .. /> is valid.

Comment 1

14 years ago
Looks like bug 181996 to me. Reporter, can you show us an url with this error ?
Is this in HTML or XHTML ?
(Reporter)

Comment 2

14 years ago
(In reply to comment #1)
> Looks like bug 181996 to me. Reporter, can you show us an url with this error ?
> Is this in HTML or XHTML ?

XHTML

Comment 3

14 years ago
XHTML or HTML is not the right question. What is the content-type?
If this is text/html, this is invalid.
Please reopen if against expectation you're sending the data as
application/xhtml+xml.

*** This bug has been marked as a duplicate of 181996 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Updated

10 years ago
Component: DOM: HTML → DOM: Core & HTML
QA Contact: ian → general
You need to log in before you can comment on or make changes to this bug.