Last Comment Bug 292649 - resizing window makes white-color ridge borders disappear and reappear
: resizing window makes white-color ridge borders disappear and reappear
Status: RESOLVED WORKSFORME
: testcase
Product: Core Graveyard
Classification: Graveyard
Component: GFX (show other bugs)
: Trunk
: x86 Windows XP
: -- normal with 1 vote (vote)
: mozilla1.8beta2
Assigned To: Zibi Braniecki [:gandalf][:zibi]
: Hixie (not reading bugmail)
Mentors:
Depends on: 135394
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-02 11:57 PDT by Eyal Rozenberg
Modified: 2014-01-16 08:22 PST (History)
4 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
testcase (507 bytes, text/html)
2005-05-02 11:59 PDT, Eyal Rozenberg
no flags Details
testcase (1.29 KB, text/html)
2005-06-11 09:57 PDT, Zibi Braniecki [:gandalf][:zibi]
no flags Details

Description Eyal Rozenberg 2005-05-02 11:57:10 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b) Gecko/20050128 Mnenhy/0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b) Gecko/20050128 Mnenhy/0.7

In addition to the problem described in bug 135394, sometimes the border drawing
is dependent on the window size (and/or rest-of-the-page content, it seems).


Reproducible: Always

Steps to Reproduce:
1. Load the testcase
2. Play around with the window size
3. Borders disappear and reappear, even seemingly independently of each other
Comment 1 Eyal Rozenberg 2005-05-02 11:59:36 PDT
Created attachment 182415 [details]
testcase
Comment 2 Eyal Rozenberg 2005-05-02 12:24:51 PDT
Actually, it may be the case that the two bugs are not that related, since
trying to change the border color, even to, say, red or green, doesn't make the
bug go away.
Comment 3 Thomas K. (:tom) 2005-05-02 14:29:04 PDT
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050419
Firefox/1.0.4

I'm not seeing the borders disappear and reappear.
Comment 4 Steve England [:stevee] 2005-05-02 14:34:36 PDT
I am seeing this, with Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2)
Gecko/20050502 Firefox/1.0+
Comment 5 Boris Zbarsky [:bz] (Out June 25-July 6) 2005-06-09 15:49:12 PDT
Iirc, we need at least 3px border width to paint a ridged border, and "thin" is
thinner than that.  We should probably be falling back on "solid" instead.
Comment 6 Steve England [:stevee] 2005-06-09 15:58:48 PDT
I'm going to hoy in a reference to bug 134942 here.
Comment 7 Zibi Braniecki [:gandalf][:zibi] 2005-06-10 04:48:34 PDT
I'm going to solve this with a method described in Comment 5.
Comment 8 Eyal Rozenberg 2005-06-10 05:12:26 PDT
No, I think it's more important that the ridge remains rather than the thinness
remains. When an author specifies a thin ridge she would expect a ridge, and as
thin as is reasonable for a ridge to be. So I submit that interpreting the
'thin' as '3px' in such cases is the right way to go.
Comment 9 Hixie (not reading bugmail) 2005-06-10 05:38:42 PDT
'thin' must (per spec) mean the same for all styles. For compatibility with the
Web, 'solid thin' must be 1px.

When we have high-resolution monitors, 'ridge thin' will be visible.
Comment 10 Zibi Braniecki [:gandalf][:zibi] 2005-06-10 05:47:11 PDT
Ian: so what we should do about this? Can we switch to solid if thin < 3px?
Comment 11 Hixie (not reading bugmail) 2005-06-11 05:16:03 PDT
You can render a ridge all the way down to two device pixels (which might be a
very small distance, such as 0.01px, if you are on a high resolution device such
as a printer or a high res screen).

However, if there are not physically enough device pixels to render the ridge,
then yeah, I guess we should fall back to solid.
Comment 12 Zibi Braniecki [:gandalf][:zibi] 2005-06-11 09:56:33 PDT
First, I think that such patch should be for groove, ridge, outset and inset as
they all seems to work in similar way.
Second, the problem is that simplest possible patch does not solve the real
problem because switching to solid if border-color is white makes the whole
border invisible. If this is proper behaviour, patch is ready
Comment 13 Zibi Braniecki [:gandalf][:zibi] 2005-06-11 09:57:24 PDT
Created attachment 185968 [details]
testcase
Comment 14 Eyal Rozenberg 2005-06-11 11:26:02 PDT
(In reply to comment #12)
> Second, the problem is that simplest possible patch does not solve the real
> problem because switching to solid if border-color is white makes the whole
> border invisible. If this is proper behaviour, patch is ready

Of course this isn't proper behavior... _something_ must be drawn which could be
claimed to resemble a very thin ridge. I suppose a gray solid border would work,
but drawing nothing is exactly why this bug was opened.

Comment 15 Zibi Braniecki [:gandalf][:zibi] 2005-06-11 12:05:00 PDT
> but drawing nothing is exactly why this bug was opened.

No. The bug is about disappearing border while resizing window. My patch fixes
this issue. The only issue left here is that if user sets color of border to
white, it is white for border-width<3px;.

Imho it's not a bad solution, but Ian is the guru here :)
Comment 16 Eyal Rozenberg 2005-06-11 12:31:02 PDT
(In reply to comment #15)
> No. The bug is about disappearing border while resizing window.

You're splitting hairs... :-( 

There is no way drawing a solid white border is acceptable behavior when a user
asks for a thin ridged border which is supposed to be mostly gray.
Comment 17 Zibi Braniecki [:gandalf][:zibi] 2013-06-12 19:30:20 PDT
WFM in Firefox 24

Note You need to log in before you can comment on or make changes to this bug.