XUL statusbar popup and context menu not working

RESOLVED INVALID

Status

()

Core
XUL
RESOLVED INVALID
13 years ago
10 years ago

People

(Reporter: Jan Dittmer, Unassigned)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050406 Firefox/1.0.2 (Debian package 1.0.2-3)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050406 Firefox/1.0.2 (Debian package 1.0.2-3)

As the descriptions says, the following xul code does not work if used in an
extension. Tested firefox/mozilla, linux/win32.
No context menu or popup menu is showing. If you remove the x before onclick
you can see, that it cannot even find the element.
I'll attach a file with the full minimal extension to reproduce.
Note, that if you install AdBlock at the same time, the popups magically work.
(http://l4x.org/sspo-build30.xpi)

<?xml version="1.0"?>

<?xml-stylesheet href="chrome://sspo/content/sspo.css" type="text/css"?> 

<overlay id="sspo-overlay" 
  xmlns="http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul">

        <popupset id="sspo_popupset">
        <menupopup id="sspo_menu" position="after_start">
                <menuitem label="testlabel"/>
        </menupopup>
        </popupset>
        <statusbar id="status-bar" insertafter="statusbarpanel-updates"        
                        class="statusbarpanel-text">
                <statusbarpanel label="SSPO"
                        context="sspo_menu" popup="sspo_menu"
                        id="ssop-statusbarpanel"
                        xonclick="alert(document.getElementById('sspo_menu'));"/>
        </statusbar>
</overlay>


Reproducible: Always
(Reporter)

Comment 1

13 years ago
Created attachment 182429 [details]
Demo extension to show the problem
Is it possible to have a non-extension XUL file showing the problem (i.e. just
something one could load in a browser)?
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/

Comment 4

13 years ago
By my reading of the code it shouldn't work, because the popupset will fail to
find anywhere to overlay.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID

Updated

10 years ago
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.