Form auto-fill fails to fill in URL (home page) field from Address Book

RESOLVED FIXED in Future

Status

Camino Graveyard
OS Integration
RESOLVED FIXED
13 years ago
8 years ago

People

(Reporter: Smokey Ardisson (offline for a while; not following bugs - do not email), Assigned: Mike Pinkerton (not reading bugmail))

Tracking

unspecified
Future
PowerPC
Mac OS X

Details

(URL)

It's not clear what info the new form-fill is supposed to fill in, since there's
no bug associated with that checkin :-) (bug 160735, bug 187454 both discuss
autofill but neither is resolved/fixed or indicate a checkin), so...

Address Book contains a field for URL (home page); many sites, e.g., blogs,
contain an "URL" field where you can enter your homepage or blog URL.  I have my
homepage set in my card in Address Book; it's not filled in (only name and
email) when doing cmd-opt-f.
(Assignee)

Comment 1

13 years ago
that's easy to add, i just didn't in the initial checkin.
Status: NEW → ASSIGNED
Target Milestone: --- → Camino0.9
(Assignee)

Comment 2

13 years ago
done.
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
This isn't working yet on Josh's blog with 20050507 (subsequent checkins like
Bonjour are in this build, so it shouldn't be "nightly lag" that's the problem) :-(

Reopening.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 4

13 years ago
find a site where it works in seamonkey and we'll talk. josh's site doesn't so
there's nothing we can do.
Target Milestone: Camino0.9 → Future

Comment 5

13 years ago
This has to do with the fact that Wallet only supports a very limited set of
keywords to work with. Joshes page uses an id and name of "url" while wallet
doesn't know what to do with that. So the same goes for any form that's using
id/name attributes that wallet doesn't know about. I have one form that uses and
id/name of work[email] and sure enough wallet doesn't understand it. The
annoying thing is safar, omniweb and other browser do handle those cases
perfectly. Wallet seems very dumb :(
FYI, bug 295333 (never filling homepage) and bug 295336 (wrong info if label
follows field) filed against Core: Form Manager.
(Assignee)

Comment 7

13 years ago
dupe

*** This bug has been marked as a duplicate of 295333 ***
Status: REOPENED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.