Need option for 24 hour timestamp.

RESOLVED WORKSFORME

Status

--
enhancement
RESOLVED WORKSFORME
14 years ago
10 years ago

People

(Reporter: hans, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2

Received timestamps (and any other dates showing up) are in american "AM/PM"
format.  There should be an option to use 24 hour timestamps.  This format has
the advantage to use less space in columns, allowing more characters for the
subject.

Reproducible: Always

Steps to Reproduce:
I thinkthunderbird is just using the system default.
(Reporter)

Comment 2

14 years ago
If TB uses system default, then we need a way to override this.  I want to run
my core OS as US_en so I get english error messages that I can paste on Google
to research the problems.  Also, some tools require a specific locale to work. 
However, I want 24 hours in TB and maybe even americans would prefer that if it
shortens a column, whitout having to change their locale.  There must be a
checkbox in preference to choose the format.
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
(Reporter)

Comment 4

13 years ago
This feature request is still relevant.  I am replying to avoid seeing this bug
being resolved automatically.
QA Contact: front-end

Comment 5

12 years ago
I agree that this would be a great feature.
Assignee: mscott → nobody
The time format depends on your locale. (on Linux: $LC_ALL or if unset $LC_TIME or if unset $LANG).

en_US has MM/DD/YYYY with AM/PM time
en_GB has DD/MM/YYYY with 24-hour time
en_DK has ISO date-time (IIUC, YYYY-MM-DD hh:mm)

There are many other possible settings, especially for English language.

My system default includes LANG='en_US.UTF-8', but, since I prefer MM/DD/YYYY and 24-hour time, I invoke Thunderbird as

    LC_TIME=en_GB thunderbird

from the "Application" property of the desktop shortcut, and it works.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 7

10 years ago
That solution is far from being user friendly.  I would like to have this report reopened as an enhancement request for a new option in Preferences where the date format can be entered by the user.
You need to log in before you can comment on or make changes to this bug.