If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

jobs.nhs.uk - Improperly displaying page

RESOLVED FIXED

Status

Tech Evangelism Graveyard
English Other
RESOLVED FIXED
13 years ago
3 years ago

People

(Reporter: u199069, Unassigned)

Tracking

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.7) Gecko/20050414 Firefox/1.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.7) Gecko/20050414 Firefox/1.0.3

I have installed all plugins, but application forms in www.jobs.nhs.uk is not
properly displayed and I am unable to recognise headings and boxes.

Reproducible: Always

Steps to Reproduce:
1.open www.nhs.uk
2.enter house officer as a keyword for search and in displayed jobs
3.look for apply, you will get an application form

Actual Results:  
Incorrect display.. not recognisable as an application.

Expected Results:  
A correct dispalay as in IE.

Comment 1

13 years ago
WFM Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050428
Firefox/1.0+ 

I get a long application form, all seems okay.  Any chance of a screenshot of
the problem?

Comment 2

13 years ago
Created attachment 182533 [details]
NHSJobs - IE vs FF (Welcome & Quick Search)

This is a screenshot on my 1024x768 screen of the top of both sites in IE and
FF.  I don't see that much of a difference on each screen, but I do see a
difference.

Could it be that IE is improperly rendering the page?

Validator for page:
http://validator.w3.org/check?uri=http%3A%2F%2Fwww.jobs.nhs.uk%2F
(Only problems are minor, which is suprisingly good)

Validator for CSS:
http://jigsaw.w3.org/css-validator/validator?uri=http%3A%2F%2Fwww.jobs.nhs.uk%2F&usermedium=all

Problem for cursor is minor (IE only pref, annoyingly lame)
display: inline-block may be the cause of the problem, but I'm not sure.

Comment 3

13 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050419
Firefox/1.0.4

Additional info: I'm not a resident of the UK and I can't get past apply's short
application form (asks for a login too) without being one, so I can't see that.
 Otherwise, things look ok.  I too would like to see a screenshot of the problem
(preferably with the problem pointed out).

Comment 4

13 years ago
The code they use is invalid, for example, they have width on the <span>:s to
have the space between the text and the form fields. Only block elements can
have width/height, not inline elements. IE has this bug where it applies the
width/height to inline elements.

--> Tech Evangelism
Assignee: nobody → english-other
Component: General → English Other
OS: Windows 98 → All
Product: Firefox → Tech Evangelism
QA Contact: general → english-other
Hardware: PC → All
Summary: Improperly displaying page → jobs.nhs.uk - Improperly displaying page
(Reporter)

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.