Autodelete RSS feed items after X days option

RESOLVED INVALID

Status

MailNews Core
Feed Reader
--
enhancement
RESOLVED INVALID
13 years ago
9 years ago

People

(Reporter: dria, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3 StumbleUpon/1.9994
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3 StumbleUpon/1.9994

I'd like to be able to set my RSS feed folders to autodelete items older than a
configurable number of days.


Reproducible: Always

Comment 1

13 years ago
I'd like this as an option too as it'll save the hassle of manually deleting
items, especially when you have a large number of feeds. The point of RSS is to
save time polling a whole bunch of websites and not having an option like this
means that you end up losing some of that time performing 'maintenance' on the
feeds! :)

RSS Bandit has a well implemented system (see http://www.rssbandit.org) BTW.

Comment 2

13 years ago
TB 1.5 will feature a 'Retation Policy' - for each folder you'll have an option
to  set when to autodelete messages:
- delete messages that are more than xxx days old or
- delete all but hte last xxx messages

Comment 3

13 years ago
Ok, cheers for info.

Any chance it could incorporate some sort of propogation down folders so that
given some feeds arranged like this:

o RSS Feeds (News & Blogs)
  o Games
    o IGN
    o GameSpy
    o Eurogamer
    o ...
  o News
    o BBC
    o SlashDot
    o ...

I could set the retention policy for 'games' or 'news' and everything underneath
it in one go? Only I normally have news items expire much sooner than blogs
(along with other less frequently updated channels) and I tend to group my feeds
into categories like this.

When is the TB 1.5 release due out BTW? Is it on the same schedule as FF 1.5?

Comment 4

13 years ago
No, currently you have to do it manually for each folder.

Roadmap says 1.5 release will be in September.
Marking INVALID since this will be in the Thunderbird 1.5 release. Whether or not the UI for this is appropriate/discoverable/optimal is a seperate bug, and I'd encourage anyone to open said bug with suggestions like the one implied in comment 3
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
Target Milestone: --- → Thunderbird1.5

Updated

9 years ago
Assignee: mscott → nobody
Component: RSS → Feed Reader
Product: Thunderbird → MailNews Core
QA Contact: rss
Target Milestone: Thunderbird1.5 → ---
You need to log in before you can comment on or make changes to this bug.