Closed Bug 292862 Opened 15 years ago Closed 15 years ago

Relative links rule differ from MSIE with "\" in base path

Categories

(Firefox :: General, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 64488

People

(Reporter: lcolautti, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; it-IT; rv:1.7.7) Gecko/20050414 Firefox/1.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; it-IT; rv:1.7.7) Gecko/20050414 Firefox/1.0.3

In the test URL, character "\" is converted in "%5C" (in MSIE, converted in
"/"). Relative paths links are broken.

Reproducible: Always

Steps to Reproduce:
1. Open reference url 
2. Click on a region (Abruzzo)
3. Click on a province (L'Aquila)
4. Click on a city (Avezzano)

Actual Results:  
NOT FOUND (404) 

Expected Results:  
Open page

I'm not sure this is a true bug. I not know exatcly the http rules but I've
frequently found "\" in url path.
Summary: Relative links (in submit button) rule differ from MSIE with "\" in base path → Relative links rule differ from MSIE with "\" in base path
"\" is invalid in URIs, use "/".

*** This bug has been marked as a duplicate of 64488 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.