Elements floated right that are wider than the viewable area will not display horizontal scrollbar

RESOLVED DUPLICATE of bug 6976

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 6976
13 years ago
13 years ago

People

(Reporter: sean madden, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2

The page above is about as streamlined as I could make it to illustrate the
problem.  If you switch it to float: left, firefox renders it just fine and
gives you the horizontal scrollbar if the viewable size is less than the
container size (in this case 900px).  The problem appears to be with elements
with float: right. 

Reproducible: Always

Steps to Reproduce:
1. Load the URL above in firefox.
2. Resize the browser width to be less than 900px.


Actual Results:  
No horizontal scrollbar appears.  The content "disappears" off the left hand
side of the page. 

Expected Results:  
I should have been given a horizontal scrollbar so that I could see the entirety
of the content.
Dupe of bug 6976 via bug 185997.

*** This bug has been marked as a duplicate of 6976 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.