Typeahead search no longer works in Chinese locale

VERIFIED DUPLICATE of bug 259454

Status

()

VERIFIED DUPLICATE of bug 259454
14 years ago
14 years ago

People

(Reporter: a.c.li, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050421 Firefox/1.0.3 (Debian package 1.0.3-2)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050421 Firefox/1.0.3 (Debian package 1.0.3-2)

Typeahead search used to work perfectly in firefox (i.e., I just press
Ctrl+Space to open the XIM, input a character, and firefox would search for it).

However, some time ago, activating typeahead would open a search box at the
bottom of the screen. Ever since this change appeared, typeahead search no
longer works; since Ctrl+F search is now the same as typeahead search, Ctrl+F
does not work either. Instead, searching text on the page would now result in:

1. nothing happening (i.e., no search box appears, and firefox does not respond
to my Chinese typing); or

2. the search box appearing, but nothing else happening after that (i.e., I
can't type anything inside the search box)

Usually, pressing / or even Ctrl+F would help to bring up the search box, but
this does not mean I can type. I can click inside the search box, but sometimes
even this does not work (typing may cause the search box to disappear). When I
can finally get firefox to accept some input, the Chinese radicals that I have
typed (inside the XIM editor) would suddenly appear inside the search box.

Reproducible: Always

Steps to Reproduce:
1. Launch firefox and open a page with some Chinese text
2. Optionally press / or Ctrl+F to bring up the search box
3. Type some Chinese using an input method

Actual Results:  
Nothing happens, or odd behaviour happens as described above

Expected Results:  
Firefox should search for the Chinese text I type

Happens with both SCIM and xcin input methods
Is this not a duplicate of bug 259454?
(Reporter)

Comment 2

14 years ago
Yes, it looks like a dup, though the other bug says to reproduce the bug you
need to press / or Ctrl+F, which I find to be not the case.

I did not find the other bug because I have never heard of "FastFind" or "Find
Toolbar".

*** This bug has been marked as a duplicate of 259454 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.