navigator.platform and platform mentioned in userAgent does not match.

VERIFIED WONTFIX

Status

()

defect
P3
normal
VERIFIED WONTFIX
20 years ago
20 years ago

People

(Reporter: desale, Assigned: vidur)

Tracking

Trunk
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Reporter

Description

20 years ago
navigator.platform and platform mentioned in userAgent does not match.

Here is an explanation. 
navigator.platform is a platform that you are running navigator under. 
navigator.userAgent specifies userAgent header which contains both the platform 
for which navigator is compiled and platform under which you are running 
navigator.

So "navigator.platform" should match with "platform under which you are running 
navigator" in the userAgent.

For example "navigator.platform" returns  "Windows". and "platform under which 
you are running navigator in the userAgent" is "Win95".

BUILDS: 02-24-09, 02-24-15.

STEPS TO REPRODUCE:
1] Please load attachment I'm going to provide with above specified builds.

OR

1] Please copy HTML code I'm providing. Save it as HTML file.
2] Open this HTML file with above specified builds.

EXPECTED RESULTS:
Navigator.platform = Win95

Navigator.userAgent = Mozilla/5.0 (Windows; N; Win95; en-US) Netscape/6.0m14 

ACTUAL RESULTS:
Navigator.platform = Windows

Navigator.userAgent = Mozilla/5.0 (Windows; N; Win95; en-US) Netscape/6.0m14

in userAgent see first windows indicates platform for which navigator is 
complied, and second Win95 indicateds which platform you are running navigator 
under. Second one should match with navigator.platform.

TESTCASE CODE START:

<HTML>
<HEAD><TITLE>Navigator Platoform</TITLE>
</HEAD>
<BODY>
<SCRIPT>
<!--
document.write('Navigator.platform = ' + navigator.platform);
document.write('<br><br>');
document.write('Navigator.userAgent = ' + window.navigator.userAgent);
//-->
</SCRIPT>
</BODY>
</HTML>

TESTCASE CODE END:
Reporter

Comment 1

20 years ago
Assignee

Comment 2

20 years ago
The test run in Navigator 4.x gives you:
Navigator.platform = Win32
Navigator.userAgent = Mozilla/4.61 [en]C-NSCP (WinNT; U) 

I believe that most people just check for the existence of the string "Win" in 
navigator.platform. Judson says that he conciously switched to "Windows". Unless 
we can find a specific page that breaks because of the switch, I don't think 
this is an issue. Marking WONTFIX.
Status: NEW → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → WONTFIX
Reporter

Comment 3

20 years ago
Verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.