anchor not styled when href has no file extension

RESOLVED WORKSFORME

Status

()

Core
CSS Parsing and Computation
RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: lesch, Assigned: dbaron)

Tracking

1.7 Branch
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1

Failed to style an anchor with no file extension

Reproducible: Always

Steps to Reproduce:
1. embed this CSS
.done, .done a { background: #005a9c; color: #fff; }

2. create a table with this cell
<td class="done"><a href=
"http://www.example.com/example">done</a></td>
3. create a table with this cell
<td class="done"><a href=
"http://www.example.com/example.html">done</a></td>


Actual Results:  
first anchor is not styled, second one is

Expected Results:  
style both

Thank you.
Created attachment 182651 [details]
Testcase

Do the two cells in this testcase look the same to you? If so, can you provide
a testcase in which you do see a problem?
Assignee: nobody → dbaron
Component: General → Style System (CSS)
Product: Firefox → Core
QA Contact: general → ian
Version: unspecified → 1.7 Branch

Comment 2

13 years ago
Created attachment 182653 [details]
Testcase in valid XHTML 1.1

A testcase in valid XHTML 1.1, approved by gavin for the purpose of testing it
in different modes.

Comment 3

13 years ago
Created attachment 182654 [details]
Testcase in valid XHTML 1.1 with style info

Oops, thanks to ct^ for the fix
Attachment #182653 - Attachment is obsolete: true
(Reporter)

Comment 4

13 years ago
I should have known better than to report this as a bug. Cannot repeat anymore.
Sorry.

Comment 5

13 years ago
Works for you and it works for me, so marking as such.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.