Html entities rendered even if there's no final ";" (like "&lang" rendered like "⟨")

RESOLVED DUPLICATE of bug 293009

Status

()

Firefox
General
--
minor
RESOLVED DUPLICATE of bug 293009
13 years ago
13 years ago

People

(Reporter: cicalona, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; it-IT; rv:1.7.6) Gecko/20050318 Firefox/1.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; it-IT; rv:1.7.6) Gecko/20050318 Firefox/1.0.2

All the html entities for symbol and greek letters are rendered with the
corresponding graphic even if the final ";" is missing (like "&lang" rendered
like "⟨") This may cause big problem with params in urls! (like: ..&lang=..) 

The bug is present also in Mozilla browser. 


Reproducible: Always

Steps to Reproduce:
1. Create an HTML page with the code oh the entities without the final ; (es.:
<html><body>&lang</body></html>)
2. Open it with FireFox/Mozilla

Actual Results:  
You see the symbol of left bracket angle instead of the string: "&lang" as expected

Expected Results:  
Display the string: "&lang"

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 293009 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Summary: Html entities rendered even if there's no final ";" (like "&lang" rendered like "&lang;") → Html entities rendered even if there's no final ";" (like "&lang" rendered like "&lang;")
You need to log in before you can comment on or make changes to this bug.