Form states are cleared on reload or Go Forward/Back on pages without framesets

VERIFIED DUPLICATE of bug 293135

Status

()

Toolkit
Form Manager
VERIFIED DUPLICATE of bug 293135
13 years ago
10 years ago

People

(Reporter: Ryuichi KUBUKI, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050505 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050505 Firefox/1.0+

Form content is cleared on reload or Go Forward/Back.

Reproducible: Always

Steps to Reproduce:
1. Write something in a form
2. Reload the page or go to another page by Bookmark then go back
Actual Results:  
The form content is cleared

Expected Results:  
The form shows the lines you wrote

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 133946 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

13 years ago
Reopening & editing the summary for clarification that it's not a dupe of bug
133946.

The trunk build Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2)
Gecko/20050504 Firefox/1.0+ works OK, so it's a regression that happened in
20050505.
Status: RESOLVED → REOPENED
Depends on: 133946
Resolution: DUPLICATE → ---
Summary: Form content is cleared on reload or Go Forward/Back → Form states are cleared on reload or Go Forward/Back on pages without framesets
Version: unspecified → Trunk
(Reporter)

Updated

13 years ago
Status: REOPENED → NEW

Comment 3

13 years ago
Is this the case all the time or only when fastforward/back is enabled?
(Reporter)

Comment 4

13 years ago
(In reply to comment #3)
> Is this the case all the time or only when fastforward/back is enabled?

Do you mean the Fastforward extension? I have no extensions installed. It just
resets form states every time I reload or go forward/back the history.

*** This bug has been marked as a duplicate of 293135 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → DUPLICATE

Updated

13 years ago
No longer depends on: 133946

Updated

10 years ago
Status: RESOLVED → VERIFIED
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.