crash when i click back to tapuz.co.il using the new fast back/forward feature

RESOLVED WORKSFORME

Status

()

Core
Document Navigation
RESOLVED WORKSFORME
13 years ago
10 years ago

People

(Reporter: Barak, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050505 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050505 Firefox/1.0+

Using the lasted build with the new fast/forward feature enabeld
after accessing www.tapuz.co.il then going another page and clicking back will
resault a crash.

Reproducible: Always

Steps to Reproduce:
1.go to http://www.tapuz.co.il and wait for at least half the page to load.
2.go to any other URL or click a link
3.click back to tapuz.co.il

Actual Results:  
Firefox Crash


Talkback crash ID: TB5609040E
Blocks: 293074
No longer blocks: 293074

Comment 1

13 years ago
Same behavior with http://www.slashdot.org
Talkback crash ID: TB5616340Q
If you use Adblock this is most likely a dupe of Bug 292923

Updated

13 years ago
Component: History → History: Session
Depends on: 292923
Product: Firefox → Core
QA Contact: history → history.session
Version: unspecified → Trunk
(Reporter)

Comment 3

13 years ago
I do not use adblock. i have SpellBound, ieview and bugmenot installed.
i also noticed it happens only when the page hasn't been loaded completly.
cc bryner

Bryner, the stack of this bug is almost similar to the one in bug 292923
The crash just seems to happen at a different moment than in that bug

Comment 5

13 years ago
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8b2) Gecko/20050505

Also seems to be a dupe of Bug 292690 	<marquee> regression causes unwanted
horizontal page-widening

The wide frame: http://www.tapuz.co.il/hp1.asp?h=0

I don't have fb-cache enabled, so no crash seen.
Maybe the cashed Marquee is producing the crash?
here is a testcase of Bug 292690 using a marquee:
https://bugzilla.mozilla.org/attachment.cgi?id=182546

Summary: crash when i click back to tapuz.co.ul using the new fast back/forward feature → crash when i click back to tapuz.co.il using the new fast back/forward feature

Comment 6

13 years ago
(In reply to comment #3)
> i also noticed it happens only when the page hasn't been loaded completly.

No. I started with loading this bug, following the bug links in comment 5,
tested the marquee, went to http://my.ynet.co.il/comics/default.asp?intPage=2 to
load another hebrew site (ok, now I see it´s english) and couldn´t crash using
BACK or Forward.
Then I loaded http://www.tapuz.co.il/hp1.asp?h=0 and got a very wide display.
I waited till I saw 'done' in the status bar, and then went 'BACK' to this bug,
no crash, FORWARD, and instantly crashed.


Previous Talkback from a page in a frameset:
http://talkback-public.mozilla.org/talkback/fastfind.jsp?search=2&type=iid&id=TB5625865E

Talkback from going back and forward once on URL above:
http://talkback-public.mozilla.org/talkback/fastfind.jsp?search=2&type=iid&id=TB5626247E

both pretty similar, Stack Signature nsDocShell::FireRestoreEvents

same Talkback as bug 292923:
http://talkback-public.mozilla.org/talkback/fastfind.jsp?search=2&type=iid&id=TB5625865E
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050506
Firefox/1.0+ 12:35 PDT beast build

following the steps in comment #0 I cannot crash anymore since patch bug 292923
landed
(Reporter)

Comment 8

13 years ago
(In reply to comment #7)
> Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050506
> Firefox/1.0+ 12:35 PDT beast build
> 
> following the steps in comment #0 I cannot crash anymore since patch bug 292923
> landed

Indeed. I cannot reproduce the crash anymore.
is there any way i can close this bug myself?
per last comment
->res/wfm
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME

Updated

10 years ago
Component: History: Session → Document Navigation
QA Contact: history.session → docshell
You need to log in before you can comment on or make changes to this bug.