Would not open this page, my very own website.

RESOLVED INVALID

Status

()

--
critical
RESOLVED INVALID
14 years ago
14 years ago

People

(Reporter: venitar, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3

When trying to open my website I get a message which says "You have chosen to
open [IE icon] home.html which is a: Hypertext Document from:
http://homepage.mac.com
What should Firefox do with this file?" 'Save to disk' is checked, and I can
either cancel or save, but I can't open the page. 

I have the same problem with Camino except it automatically opens the page with
Internet Explorer. (My default browser is Safari) I've tried it several time
with both browsers and have now trashed several copies of the home page off my
desktop.

I have five browsers available so I can check my website with each one. I'm
hoping to completely eliminate Internet Explorer, but I need Firefox and/or
Camino first.

Venita
http://homepage.mac.com/venitar/home.html

Reproducible: Always

Steps to Reproduce:
1.Open Firefox or Camino
2.Go to http://homepage.mac.com/venitar/home.html
3.

Actual Results:  
As described above.

Expected Results:  
The page should have opened.

Comment 1

14 years ago
fix your content type, it's currently "HTML", it needs to be text/html

Comment 2

14 years ago
Sorry about that rude comment.

Also, I was wrong, it's currently application/octet-stream.  Firefox just shows
"HTML" because it uses the filetype when it doesn't know what it is (that's what
application/octet-stream is, the server doesn't know what filetype your file is).

I would highly suggest validating your page to find any obvious errors, right
now it can't validate it due to this.

http://validator.w3.org/check?uri=http%3A%2F%2Fhomepage.mac.com%2Fvenitar%2Fhome.html

What should work to fix it:

1) Make a text file
2) place this line in it:
      AddType text/html .html
3) Upload this file to the webserver
4) Rename the file ".htaccess"

Please note if you already have a .htaccess, just add the line to it.

Comment 3

14 years ago
This seems to be a problem caused by the transfer from your local system to your
DotMac account. You can find more about this here:

http://discussions.info.apple.com/webx?14@544.MTiCaiMQRTq.0@.68aaff49
http://discussions.info.apple.com/webx?128@470.P3qhaq6KWa0.1@.68ab8266

This is not a bug in Firefox -> INVALID
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID

Comment 4

14 years ago
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050503
Firefox/1.0+

I hesitate before wading in, and will wade out agin, on
request.

There are two identifiable problems or 'issues' here, both of
which are fixable, but which are of totally different
character.

1. Your page home.html does indeed seem to have its
Content-Type: announced as application/octet-stream . I would
have thought that this would be quite difficult to do, as the
file contains text and has an easily recognisable extension.

I would suggest that either the configuration of your .mac
homepage site is incomplete, or less likely, has some subtle
error that is having a significant effect. I doubt that you
will be happy with your site until this is fixed.

The above comment 3 seems to apply in full measure: This is a
problem with Finder.

2. I really think that Firefox's responses and diagnostics are
misleading at best and very definitely susceptible of some
improvement.

a) For me, the 'Not Specified Type' dialogue says:

    You have chosen to open
    
        home.html
        
    which is a: Hypertext
    from: http://homepage.mac.com
    
    What should the browser do with this file?
    
    
IMHO, nearly every part of this is wrong to a greater or
lesser extent (and there are Bugs open on the significant
ones), but before you blow me off, let me take the one that
made me decide to comment here at all.


*   which is a: Hypertext


Is hypertext a noun? If so, how is it being used to describe
the resource 'home.html' IMHO, describing a resource such as a
web page as 'a Hypertext' is simultaneously seemingly an
attempt to blind with science and insulting, a bit like saying
that I got something from the 'Interweb'. I appreciate that
most people here would read past an infelicity like this one,
but I really feel that this ought not to be considered
acceptable to be presented to an end user.

Moving swiftly on:

i) We haven't 'chosen to open' it, we have tried to view, or
access it. In short, we have requested this resource.

ii) If Firefox can classify it as a Hypertext Document
(presumably from the extension), then Firefox should give a
much better, clearer and fuller account of what is going on.
Firefox requests and handles Hypertext Documents all day long.
It should not whine about being asked to do so.

iii) The from line is a partial url: If a URL is required here
then http://homepage.mac.com/ would be better and it should be
selectable.

I suspect, though that this would read better if the 'http://'
substring were removed and the from line said "From the Host:"
or "From the Server:". This is clear and precise, and has the
advantage that if we actually were dealing with a malicious
site, that fact might stick out. Unfortunately, the key
information from the Reporter's POV is the piece that is at
risk of being elided: namely the path on the server and the
corresponding fact that it was the Reporter's own site with
which Firefox was not playing ball. (FWIW, I don't believe
that there is a complete solution to this - there is neither
room, nor an obvious place in the dialogue for either the URL
or the path on the server and there is potential for confusion
if either were shoe-horned in. Since this is interactive the
user might remember the URL he or she clicked on, or it might
be visible in one of Firefox's windows). Perhaps the full URL
should be a tooltip over the filename.

iv) Personally, I think that there should be two additional
choices for what the browser could do:

	( ) View as HTML
	( ) View as Text

The former could be the default in a case like this where the
Content-Type can be determined from the extension. These will
cover the two most common cases: The resource is a standard
html document but the server is misconfigured, and the
resource is a text document, but Firefox is treating it as
something else exempli gratia Javascript programs, comma
separated variable files, SQL programs. They will also cover a
wide assortment of less common and miscellaneous cases, after
all the main reason for putting a resource on the WWW is so
that a browser can display it - sometimes Firefox needs some
encouragement, but very often there is nothing wrong with the
resource.

(I will leave images and media in general for another day)

In the present case telling Firefox to pass the resource off
to Camino does what one would expect - Camino opens it. If
Firefox is happy to tell Camino to open a file as html, why
"won't" Firefox do the same!

iv) The dialogue does not give the offending mime type. Whilst
there is no obvious place for it, it could be part of the
title, videlicet:

      Unregistered Content-Type: application/octet-stream home.html
      
which also makes it reasonably clear what is going on and why.

b) Kindly note that Firefox should not be allowed to sniff
content, or at least, not without being specifically asked.
This is most definitely not what is wanted here.

c) My understanding is that the relevant RFC allows
insufficiently labelled pages to be opened as HTML provided
that the user has been warned.

d) The 'Do this automatically for files like ..." ought to be
removed from the GUI. I can't imagine circumstances when it
could be useful, and if the functionality is required it
should be part of about:config without an interface.

The whole point of this dialogue is that it means that
Firefox cannot continue without user intervention. Offering
to bypass it is bordering on the fatuous

e) When clicking the choose button it should come up in
/Applications with 'Recommended Applications' not the user's
home or Documents folder.

f) Finally, particularly when ii) and iv) apply the default
choice should be OK not Cancel.

It is really hard to get UI changes to Firefox considered, let
alone implemented, but if it is felt that any of my points
need to added to Bugzilla as separate reports I will do so,
and I am happy to create patches (at least for the simple
cases). I repeat that it is astonishing that the existing
system (though I appreciate it is standards based) is considered
appropriate for end users.

Comment 5

14 years ago
There is a page that gives an entire grid of test cases at
http://entropymine.com/jason/testbed/mime/
You need to log in before you can comment on or make changes to this bug.