Problem with -p vs. -P option on command line

RESOLVED FIXED

Status

--
trivial
RESOLVED FIXED
14 years ago
6 years ago

People

(Reporter: pdonahue, Assigned: Biesinger)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20040913
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20040913

http://www.mozilla.org/docs/command-line-args.html says to use "-p profile" to
launch mozilla with a different profile.  However, the mozilla shell script
grabs -p and tries to run mozilla-bin.pure, which doesn't exist.

mozilla --help says to use "-P profile" to do the same thing.  I suppose that
this is more authoritative.  This uppercase P works as expected.

At the very least, there is a bug in the CLI web page above.  But when I comment
out these lines from the mozilla shell script:
    -p | -pure)
      MOZILLA_BIN="mozilla-bin.pure"
      shift
      ;;
it passes a lowercase "-p profile" to mozilla-bin and it uses that profile. 
Essentially, this means that the binary will accept either -p or -P.  Odd.

I don't know what mozilla-bin.pure is, but should the tarball be sent out with
mozilla-bin.pure symlinked to mozilla-bin?  Of course, this wouldn't have fixed
by problem because mozilla-bin would be executed with "myprofile" as one of the
arguments since the script only consumed the -p and not the next word.


Reproducible: Always

Steps to Reproduce:
1. mozilla -p myprofile -remote "openurl(http://cnn.com/,new-window)"

Actual Results:  
run-mozilla.sh: Cannot execute /home/pdonahue/tools/Linux/mozilla/mozilla-bin.pure.
the web page is wrong
Assignee: general → cbiesinger
Status: UNCONFIRMED → NEW
Component: General → webmaster@mozilla.org
Ever confirmed: true
Product: Mozilla Application Suite → mozilla.org
QA Contact: general → danielwang
Version: unspecified → other
Checking in mozilla-org/html/docs/command-line-args.html;
/cvsroot/mozilla-org/html/docs/command-line-args.html,v  <--  command-line-args.html
new revision: 1.12; previous revision: 1.11
done

the web page should update w/in 15 minutes or so.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Comment 3

14 years ago
You might also want to change the example from
mozilla -p "Joel User"
to
mozilla -P "Joel User"
thanks, fixed
Checking in mozilla-org/html/docs/command-line-args.html;
/cvsroot/mozilla-org/html/docs/command-line-args.html,v  <--  command-line-args.html
new revision: 1.13; previous revision: 1.12
done
Product: mozilla.org → Websites
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.