If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

When ActiveX control plug-in is installed buttons in a flash document no longer work.

RESOLVED FIXED in mozilla1.8beta3

Status

Core Graveyard
Embedding: ActiveX Wrapper
RESOLVED FIXED
13 years ago
6 years ago

People

(Reporter: Tony Simone, Assigned: emk)

Tracking

Trunk
mozilla1.8beta3
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3

When you click on the buttons in Macromedia Flash Player it should take you to
another page but with the Active X plugin installed nothing happens. Once the
nsIMozAxPlugin.xpt and the npmozax.dll files are removed Macromedia Flash Player
works again.

Reproducible: Always

Steps to Reproduce:
1.Install ActiveX control plug-in from
http://www.iol.ie/~locka/mozilla/plugin.htm#links
2.Go to http://www.macromedia.com/shockwave/welcome/
3.Click on the buttons in the Macromedia Flash Player area

Actual Results:  
When you click on the buttons in Macromedia Flash Player it should take you to
another page but with the Active X plugin installed nothing happens.

Expected Results:  
The ActiveX plugin works correctly but causes a conflict with Macromedia Flash
Player.
Assignee: nobody → adamlock
Component: File Handling → Embedding: ActiveX Wrapper
Product: Firefox → Core
QA Contact: file.handling → dunn5557
Version: unspecified → 1.7 Branch
(Assignee)

Comment 1

13 years ago
Created attachment 188308 [details] [diff] [review]
Patch rv1.0

Taking.
OnLinkClick() now requires valid nsIContent pointer due to fix for bug 201839.
Assignee: adamlock → VYV03354
Status: UNCONFIRMED → ASSIGNED
Attachment #188308 - Flags: superreview?(jst)
Attachment #188308 - Flags: review?(jst)
Comment on attachment 188308 [details] [diff] [review]
Patch rv1.0

r+sr=jst
Attachment #188308 - Flags: superreview?(jst)
Attachment #188308 - Flags: superreview+
Attachment #188308 - Flags: review?(jst)
Attachment #188308 - Flags: review+
(Assignee)

Comment 3

13 years ago
Comment on attachment 188308 [details] [diff] [review]
Patch rv1.0

Very safe fix. ActiveX Plug-in is turned off by default.
Attachment #188308 - Flags: approval1.8b3?

Updated

13 years ago
Attachment #188308 - Flags: approval1.8b3? → approval1.8b3+
Checking in embedding/browser/activex/src/plugin/XPCDocument.cpp;
/cvsroot/mozilla/embedding/browser/activex/src/plugin/XPCDocument.cpp,v  <-- 
XPCDocument.cpp
new revision: 1.28; previous revision: 1.27
done

-> FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.8beta3
Version: 1.7 Branch → Trunk
Component: Embedding: ActiveX Wrapper → Embedding: ActiveX Wrapper
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.