In lists, 'disc' symbols rendered as diamond in spite of <ul type="disc"> being used

RESOLVED DUPLICATE of bug 204135

Status

()

RESOLVED DUPLICATE of bug 204135
14 years ago
8 years ago

People

(Reporter: cv2pf6ip50, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 1.0.3705; .NET CLR 1.1.4322)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3     [and all previous versions]

In the page at http://truecrypt.org/history.php, there is a list (but it 
applies to other pages as well). The list uses <ul type="disc">. 

Official W3C specification say:
''User agents should attempt to present a "disc" as a small filled-in circle, 
a "circle" as a small circle outline, and a "square" as a small square 
outline.''

However, Firefox 1.0.3 and all previous versions display diamonds instead of 
filled-in circles.

Reproducible: Always

Steps to Reproduce:
1.Just compare the page in IE and Firefox.
2.
3.



Expected Results:  
Present a "disc" in lists as a small filled-in circle (not as a diamond).

Comment 1

14 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050504
Firefox/1.0+

I can't find anything else to dupe this to.  It happens here.  Changing URL to
W3 spec page since reporter has already posted URL of example page in his report.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

14 years ago
Created attachment 182933 [details]
Page demonstrating discs, circles, and squares

After making this testcase, I realize that you see discs which look like
diamonds.  Perhaps we need to replace our discs with better discs?

Comment 3

14 years ago
Created attachment 182934 [details]
Works for me on trunk in Mac OS X 10.2.8

Works for me on the trunk under Mac OS X 10.2.8
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050507
Firefox/1.0+

(and the testcase too)

Comment 4

14 years ago
dupe of bug 204135
see also bug 152588 comment 6

*** This bug has been marked as a duplicate of 204135 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.