Rendering wrong when using images and absolution positionning, OK after refresh.

VERIFIED WORKSFORME

Status

()

Core
Layout
VERIFIED WORKSFORME
13 years ago
13 years ago

People

(Reporter: vic, Unassigned)

Tracking

1.0 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050425 Firefox/1.0.3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050425 Firefox/1.0.3

When using an image tag followed by an absolutely positionned block, the
positionning of the block does not take the image into account. However afer a
refresh the positionning is done correctly.

Reproducible: Always

Steps to Reproduce:
1. Write the following code in a file :
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
  <head>
    <title>Rendering bug</title>
  </head>
  <body>
    <img
src="http://sfx-images.mozilla.org/affiliates/Banners/120x600/trust.png"
alt="test image">
    <div style="position: absolute">This text should appear under the image.
Reload and see the layout change.</div>
  </body>
</html>

2. Open the file in firefox (close firefox first to clear the cache)
3. See how the text overlaps the image
4. Hit reload
5. See the different positionning, this time the text is under the image

Actual Results:  
The text overlaps the image the first time, but not after the image has been cached.

Expected Results:  
Text should be under the image. Presumably the positionning is wrong the first
time because when the layout is calculated the image has not yet been loaded and
firefox thinks its height is zero. The layout is correct if the image is already
in cache.

Comment 1

13 years ago
Created attachment 182935 [details]
reporters testcase

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050504
Firefox/1.0+

Looked fine for me before and after a refresh.

Comment 2

13 years ago
WFM: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050507
Firefox/1.0+

This has been fixed. Please test with nightly trunk builds before filing layout
bugs, thanks
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Component: General → Layout
Product: Firefox → Core
Resolution: --- → WORKSFORME
Version: unspecified → 1.0 Branch

Comment 3

13 years ago
Verifying that this looks fine now.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 4

13 years ago
Oh well .. I thought this version was recent enough.
Still doesn't work for me with 1.0.4 (Mozilla/5.0 (X11; U; Linux i686; en-US;
rv:1.7.8) Gecko/20050513 Firefox/1.0.4) though, is there a difference between
main releases and trunk source?

Comment 5

13 years ago
(In reply to comment #4)
> Still doesn't work for me with 1.0.4 (Mozilla/5.0 (X11; U; Linux i686; en-US;
> rv:1.7.8) Gecko/20050513 Firefox/1.0.4) though, is there a difference between
> main releases and trunk source?

All Firefox 1.0.x versions are based on gecko 1.7 layout engine. Firefox 1.1
will have the gecko 1.8 layout engine that contains this fix. 
You need to log in before you can comment on or make changes to this bug.