If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Mozilla crashes if you type "shift-left-arrow" while entering data in a text form to select a region of text

RESOLVED WORKSFORME

Status

()

Firefox
General
--
critical
RESOLVED WORKSFORME
13 years ago
7 years ago

People

(Reporter: Phillip Conrad, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.7) Gecko/20050414 

The web page listed above provides a means to "write to your congressman".   

Two screens after the "entry screen" listed in the URL, you are presented a 
text box for your "letter to your congressman".

In that text box I was typing a letter when I wanted to "select a region of 
text" to cut and paste.   One can do this with the mouse, but to be more 
efficient and key my fingers on the keys, I typically do it by holding down 
shift, and navigating with the arrow keys. (In fact, I've done that several 
times while typing this bug report... using IE).   In Firefox though, this 
causes Firefox to crash.   

The "shift-arrow" habit is so ingrained, I can't stop myself.  Even if Firefox 
doesn't support that set of keystrokes, it still shouldn't crash.

I'm a big fan of Firefox, and it makes me sick to my stomach to have to use 
IE, but I've tried sending my letter to my congressman three times now (each 
time, losing 10 minutes worth of typing).  So, sadly, until this bug is fixed, 
I must click the "View this page in IE" extension anytime I have to enter more 
than a few characters of text.

It doesn't happen in all text forms.  I copied and pasted a portion of the 
HTML code for the form to 

http://www.cis.udel.edu/~pconrad/work/html/test3.html 

and found that this was enough to reproduce the problem.   This html file 
contains an unclosed <dd> tag.. this is in the original source for the page 
that crashes (i.e. the one from the US House of Representatives web site.)    
Acknowledged that the HTML is badly formed.. still it shouldn't crash!



Reproducible: Always

Steps to Reproduce:
1. Go to a page with an unclosed <dd> tag before a textbox (such as 
http://www.cis.udel.edu/~pconrad/work/html/test3.html, or the US House of 
Representatives "write your congressman page").
2. Enter text in the textbox.
3. Hold down shift, and hit left arrow.
4. Mozilla crashes.

Actual Results:  
Mozilla crashes.

Expected Results:  
Don't crash.. just let the text be "selected".  (This is what occurs when 
there is not an unclosed <dd> tag before the <textbox> element.
Do you have a talkback ID from thyt crash ?

Comment 2

13 years ago
This works for me using Mozilla/5.0 (Windows; U; Windows NT 5.1; fr-FR;
rv:1.7.7) Gecko/20050414 Firefox/1.0.3 and Mozilla/5.0 (Windows; U; Windows NT
5.1; en-US; rv:1.8b2) Gecko/20050507 Firefox/1.0+ . I think this issue is local.
Please try with a new profile http://www.mozilla.org/support/firefox/profile. Or
get support http://www.mozilla.org/support/.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

13 years ago
WFM too. Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2)
Gecko/20050507 Firefox/1.0+

Comment 4

13 years ago
Reporter: There has been a lot of work on selection since the 20050414 build.
Could you try with the latest-trunk please?

WFM 20050508
(Reporter)

Comment 5

13 years ago
(In reply to comment #4)
> Reporter: There has been a lot of work on selection since the 20050414 build.
> Could you try with the latest-trunk please?
> 
> WFM 20050508
> 

How do I do that?

Comment 6

13 years ago
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050508
Firefox/1.0+

WFM. This bug is probably platform specific.

Updated

13 years ago
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME

Comment 7

13 years ago
More important in this case would be the new profile I think but latest trunk
can help to ... get it here
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/
 this is a devellopement version.
You need to log in before you can comment on or make changes to this bug.