All users were logged out of Bugzilla on October 13th, 2018

VoiceOver support under Mac OS X 10.4 Tiger needed

RESOLVED DUPLICATE of bug 157209

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 157209
14 years ago
14 years ago

People

(Reporter: joeclark, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Firefox requires specific testing and optimization for VoiceOver, the screen
reader built into Mac OS X 10.4 Tiger. Currently Firefox pretty much does not
work with VoiceOver (certainly compared to Safari).

* Preferences window cannot be read even with the Interact with Item keystroke,
Ctrl-Option-Shift-downarrow.

* Cannot move VoiceOver cursor off the address field (called "scrollbar").

* When manually clicking inside Web content to reposition focus, which an actual
blind person would be unlikely to do, reading starts at a tiny, ~15-px-wide bar
along the left edge of the Web area (also "scrollbar"), where you remain
trapped, apparently forever.

Reproducible: Always

Steps to Reproduce:
1. Start VoiceOver on Tiger (Command-F5).
2. Using the documented keystrokes, attempt to use Firefox.
Actual Results:  
As listed above.

Expected Results:  
Allowed me to move at will, use Preferences, and read Web content unhindered.

Camino, Thunderbird, and Mozilla should also be compatible with VoiceOver.
Actually, any Mac OS application from the Foundation should be.

Since VO does not use an API that is external to the browser (like MSAA) but
uses OS-level functions, it may be easier to provide VO compatibility than, say,
Jaws or Window-Eyes compatibility on Windows.

*** This bug has been marked as a duplicate of 157209 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.