Message sent before logging into mail shows "login failed" dialog

VERIFIED FIXED in M14

Status

MailNews Core
Composition
P3
normal
VERIFIED FIXED
18 years ago
10 years ago

People

(Reporter: Phil Peterson, Assigned: jefft)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+] Fix in hand. Waiting for reviewing and approval...)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Using today's build on NT



1. Run mozilla, starting up in the browser

2. Ctrl-N to bring up a new mail message

3. Type some stuff and send mail message



Expected: get password dialog asking me to log in to the IMAP server to copy the

outgoing message to my IMAP Sent folder



Actual: get "login failed" alert box, and compose window comes back up. Message

was actually sent.
(Reporter)

Comment 1

18 years ago
Nominate for beta1
Keywords: beta1

Comment 2

18 years ago
This is probably the same cause as 
http://bugzilla.mozilla.org/show_bug.cgi?id=28266 (?)

Comment 3

18 years ago
I think this is actually the copy operations (i.e. the copy service) that is
driving this part of the process. It sounds like if we solve this once, it will
be solved for everything and I would think that the copy service may be the
place to address it.

Jeff, let me know if you think I'm off on this one.

- rhp
Assignee: rhp → jefft
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: M14

Comment 4

18 years ago
Putting on PDT+ radar for beta1.
Whiteboard: [PDT+]
(Assignee)

Comment 5

18 years ago
The reason it failed is because we are passing in null nsIMsgWindow when calling 
CopyFileMessage from nsMsgCopy::DoCopy(). nsIMsgWindow may not be available in 
the compose land. The right fix seems to me would be use hthe idden window when 
we cannot get hold of a nsIMsgWindow. I'll work on 
nsMsgIncomingServer::GetPasswordWithUI() to make sure we try to use the hidden 
window when nsIMsgWindow is not available.
(Assignee)

Updated

18 years ago
Whiteboard: [PDT+] → [PDT+] Fix in hand. Waiting for reviewing and approval...
(Assignee)

Comment 6

18 years ago
Created attachment 5889 [details] [diff] [review]
Proposed fix

Comment 7

18 years ago
*** Bug 29537 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 8

18 years ago
Fix checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 9

18 years ago
verified this on Win32 2000-03-02-09-m15 commercial build.  
Still need to verify on Linux and Mac builds.

Comment 10

18 years ago
fenella, pls help to verify. Thanks.
QA Contact: lchiang → fenella

Comment 11

18 years ago
Linux (2000-03-07-09 M15) commercial build
Win32 (2000-03-07-09 M15) commercial build
Mac (2000-03-07-08 M15) commercial build
Verified that the problem is gone in all these builds.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.