window.print(); in german version sets page-size 'letter' instead standard 'A4'

RESOLVED DUPLICATE of bug 156992

Status

()

Core
Printing: Output
RESOLVED DUPLICATE of bug 156992
13 years ago
13 years ago

People

(Reporter: cornholio, Unassigned)

Tracking

1.7 Branch
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; de-DE; rv:1.7.7) Gecko/20050414 Firefox/1.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; de-DE; rv:1.7.7) Gecko/20050414 Firefox/1.0.3

If a page is opened in a firefox session and no page has been printed before in
that session, and this page executes the javascript call "window.print();" then
the page-size int he printer properties shows 'letter' instead of the german
standard 'A4'. If printing is started through the menu, then paper-size defaults
to 'A4' correctly. Every subsequent call to window.print() has the correct
paper-size set for the rest of the session.

Reproducible: Always

Steps to Reproduce:
1. open firefox(german version), new session
2. open a page that executes window.print();
3. printer selection/properties window appears
Actual Results:  
check paper-size in print properties, is 'letter'

Expected Results:  
paper-size should be 'A4'
Assignee: nobody → printing
Component: General → Printing
Product: Firefox → Core
QA Contact: general
Summary: window.print(); in german version sets page-size 'letter' instead standard 'A4' → window.print(); in german version sets page-size 'letter' instead standard 'A4'
Version: unspecified → 1.7 Branch

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 156992 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.