Mozilla should have built-in support for all standard platforms

RESOLVED DUPLICATE of bug 92110

Status

()

Core
DOM: Core & HTML
--
enhancement
RESOLVED DUPLICATE of bug 92110
13 years ago
10 years ago

People

(Reporter: jdperlow, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3
Build Identifier: 

A browser appliction author cannot depend on the browser to provide sound
support (simple ability to play a wav file). It depends on what else happens to
be installed on the computer (e.g. flash, quicktime, etc.,). Also, even when a
pluggin is installed that supports it, the behavior varies depending on which
pluggin and version happens to be installed. For example, we've found some
pluggins cause the browser to freeze while the sound is being downloaded or
cause focus to be lost when the sound is played.

Sound support should be part of the baseline mozilla platform like it is part of
the base IE platform. It should have a predictible download and play behavior
that is consistent and reliable across all platforms.

Reproducible: Always
Severity: normal → enhancement

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 92110 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Comment 2

13 years ago
Is this really a duplicate of bug 92110?

jst: this bug seems to be more about playing sound files via the DOM or via some
plugin.  does that mean this bug belongs in some plugin or DOM category instead?

Comment 3

13 years ago
Darin: Feel free to reopen if you disagree.

See also bug 179586 (which has been WONTFIXed without a lot of discussion).

Updated

10 years ago
Component: DOM: HTML → DOM: Core & HTML
QA Contact: ian → general
You need to log in before you can comment on or make changes to this bug.