downloading Tiger from Apple Developer Connection yields corrupt .dmg file

RESOLVED DUPLICATE of bug 290236

Status

()

Toolkit
Downloads API
--
critical
RESOLVED DUPLICATE of bug 290236
13 years ago
10 years ago

People

(Reporter: Jeremy Todd, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3

When downloading OS X Tiger (10.4) from connect.apple.com (the Apple Developer 
Connection), the download completes but the .dmg file "contains no mountable 
filesystems". When downloading with Safari the .dmg file can indeed be mounted, 
so I believe Firefox is corrupting the file.

The specific file is the release build of Tiger, 
named "tiger_8a428_userdvd.dmg". A Firefox download yields 2147483647 bytes 
while a Safari download yields 2427095245 bytes.

I repeated the Firefox download three times to make sure it was reproducible, 
and indeed it produced the same result each time.


Reproducible: Always

Steps to Reproduce:
1. visit connect.apple.com (you need an ADC membership)
2. download tiger_8a428_userdvd.dmg with Firefox 1.0.3
3. note that the resulting .dmg file contains no mountable filesystems
4. repeat with Safari, note that the resulting .dmg file contains mountable 
filesystems.


Actual Results:  
My local copy of the .dmg file contained no mountable filesystems

Expected Results:  
My local copy of the .dmg file should have matched the Safari download, 
containg mountable filesystems.

*** This bug has been marked as a duplicate of 290236 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.