crash by tesing 'Layout Regression Tests'

RESOLVED DUPLICATE of bug 292717

Status

()

Core
XBL
RESOLVED DUPLICATE of bug 292717
13 years ago
13 years ago

People

(Reporter: Hideo Saito, Unassigned)

Tracking

({crash, regression})

Trunk
All
Windows 2000
crash, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
When I tested following "Layout Regression Tests", Mozilla crashed.
 http://www.mozilla.org/newlayout/doc/regression_tests.html

The testcase causing a problem is http://www.hixie.ch/tests/evil/xml/010.xml.

mozilla-2005-02-25/Trunk has no problem,
mozilla-2005-02-26/Trunk has a problem.

I point the fault as follows. The calling |binding->MarkForDeath()| causes
memory fault, since the binding object is destroyed by calling |SetBinding|.

at ./content/xbl/src/nsBindingManager.cpp
nsBindingManager::RemoveLayeredBinding(nsIContent* aContent, nsIURI* aURL)
{
  nsXBLBinding *binding = nsBindingManager::GetBinding(aContent);
  
  if (!binding) {
    return NS_OK;
  }

  ...
  
  // Finally remove the binding...
  binding->UnhookEventHandlers();
  binding->ChangeDocument(doc, nsnull);
  SetBinding(aContent, nsnull);
  binding->MarkForDeath();        <-------------- causes memory fault

Comment 1

13 years ago
I guess thats a regression from bug 194834,
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2005-02-25&maxdate=2005-02-26&cvsroot=%2Fcvsroot
I have seen that crash too, but was to lazy to file a bug (shame on me)
Keywords: crash, regression

Updated

13 years ago
Assignee: nobody → general
Component: Layout → XBL
OS: All → Windows 2000
QA Contact: layout → ian
Looks like bug 292717, right?

Comment 3

13 years ago
yep, there you go

*** This bug has been marked as a duplicate of 292717 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.