All users were logged out of Bugzilla on October 13th, 2018

Mail Compose broken (OpenComposeWindow/ComposeMessage)

RESOLVED WORKSFORME

Status

--
major
RESOLVED WORKSFORME
14 years ago
14 years ago

People

(Reporter: InvisibleSmiley, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b2) Gecko/20050507 MultiZilla/1.8.0.1g
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b2) Gecko/20050507 MultiZilla/1.8.0.1g

The mail compose window is broken in builds after 20050507 (checked with
self-compiled 20050508 and 20050509).

Reproducible: Always

Steps to Reproduce:
1. Build/download current nightly
2. Try to open compose window
3. Check the JavaScript console

Actual Results:  
No compose window appears; JavaScript error:

Error: uncaught exception: [Exception... "Cannot find interface information for
parameter arg 4 [nsIMsgComposeService.OpenComposeWindow]"  nsresult: "0x80570006
(NS_ERROR_XPC_CANT_GET_PARAM_IFACE_INFO)"  location: "JS frame ::
chrome://messenger/content/mailCommands.js :: ComposeMessage :: line 224"  data: no]

Expected Results:  
Compose window should appear, no JavaScript error should not.

Maybe it's just me. If noone can confirm this, I can provide my .mozconfig.

Even though I currently have MultiZilla installed, I tested with unmodified
builds installed and a fresh profile.

Comment 1

14 years ago
I had the very same problem and error when building Seamonkey from trunk, but
thanks to Neil (again and again :-D ) I was able build after blowing away the
respective .xpt file: either build with |distclean| or kill all .xpt files under
$OBJDIR/mailnews/* before compiling.
(Reporter)

Comment 2

14 years ago
OK, you're right. I had a 'make distclean' in my build script, but a 'make -f
client.mk distclean' seems to be necessary in order to take care of an
alternative OBJDIR.

Resolving INVALID. Thanks for the hint!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID

Updated

14 years ago
Resolution: INVALID → WORKSFORME
You need to log in before you can comment on or make changes to this bug.