images using faked transparency render very slowly

RESOLVED DUPLICATE of bug 64401

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 64401
13 years ago
13 years ago

People

(Reporter: thedarkprince, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; hu-HU; rv:1.7.6) Gecko/20050223 Firefox/1.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; hu-HU; rv:1.7.6) Gecko/20050223 Firefox/1.0.1

In the page http://evilboris.greg2k.com/cotton/bmchars.html there are several
images using old-school transparency faking. This method to simulate
half-transparent images works by having one pixel with full opacity followed by
one pixel with zero opacity. This is almost impossible to notice on high
resolutions as the pixels almost "blend" together, creating a nice faked
transparency effect. Many old console games indeed used this method to fake
transparency effects on the limited hardware available at the time, infact the
images themselves are from such an old console game. (note: if you do not
understand my explanation, please open the character portrait picture on the
left side of the page in an image editor and enlarge them to see what I mean.
English is not my main language, and I can't explain it any better, sorry about
this.)
In Firefox, pictures using this faking method take a lot of CPU time to render,
making the site display very slowly. This is the most noticable when scrolling
the page.

Although its true that the page is not W3C valid, and uses some other things
that can hit the performance of the browser (overuse of tables, still background
images, etc.), The various other parts of the site you can visit from 
http://evilboris.greg2k.com/cotton/ also use the same elements while maintaining
a steady and fast rendering speed with absolutely no noticable slowdown. So,
it's most likely a bug in the image rendering engine of Firefox and browsers
using the same engine. Also, even with the removal of said elements that could
cause slowdown, the pictures using the faked transparency will still slow down
the scrolling.

In Microsoft Internet Explorer 6, this bug does not happen. I have not tested it
on other browsers, people did reported the same bug on Netscape however. I also
have not tested it under different OS, only Windows XP.

Reproducible: Always

Steps to Reproduce:
1. Create an image with the above explained "fake transparency" in it, and put
some of them on a webpage, most likely on a webpage that is big enough to
require scrolling it.
2. View the page and see that it renders very slowly.
3. If the effect is not noticable, try adding several of the same images to the
page and check it again.

Actual Results:  
The problem explained in the details.

Expected Results:  
The software should have rendered the pages without any, or at least very
minimal speed loss. 

My computer is an Athlon XP+ running at 2100Mhz with a Geforce 4 MX video card,
with the display set to 1152x768 in 32bpp mode with 85Hz monitor refresh rate.
This is more then enough to render the page at correct speed in Firefox, as it
does in Internet Explorer 6.

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 64401 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.