If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

packager requires GNU tar

RESOLVED DUPLICATE of bug 260174

Status

()

Core
Build Config
RESOLVED DUPLICATE of bug 260174
13 years ago
12 years ago

People

(Reporter: Stefan Blobner, Unassigned)

Tracking

Trunk
HP
HP-UX
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; HP-UX 9000/785; en-US; rv:1.8a6) Gecko/20050119
Build Identifier: Mozilla/5.0 (X11; U; HP-UX 9000/785; en-US; rv:1.7.7) Gecko/20050510 Firefox/1.0.3

After building Firefox, the packaging fails on HP-UX due to the usage of the tar
command:

Compressing...
cd ../../dist; tar -c --owner=0 --group=0 --numeric-owner --mode="go-w" -f -
firefox | gzip -vf9 > firefox-1.0.3.en-US.hpux11.11-hppa2.0w-gtk1.tar.gz
tar: cannot open /dev/rmt/0m

on HP-UX the '--*' parameters (owner/group/mode/numeric-owner) are not supported
and tar assumes that these are filenames, so in the end it doesn't read the '-f
-' parameter.

so a fix could be done in ./toolkit/mozapps/installer/packager.mk, line 74 to
fix this:

CREATE_FINAL_TAR = tar -cf

and in line 227

 @echo "Compressing..."
 @chmod -R go-w $(DIST)/$(MOZ_PKG_APPNAME)
 @chown -R 0:0 $(DIST)/$(MOZ_PKG_APPNAME)
 cd $(DIST); $(MAKE_PACKAGE)

Reproducible: Always

Steps to Reproduce:
package the build

Updated

13 years ago
Status: UNCONFIRMED → NEW
Component: Build Config → Build Config
Ever confirmed: true
Product: Firefox → Core
QA Contact: build.config → build-config
Summary: packaging the Firefox build fails due to tar usage → packager requires GNU tar
Version: unspecified → Trunk
I remember seeing a bug about this for Solaris, perhaps with a patch, but I
can't find it.

Comment 2

13 years ago
Bug #260174 perhaps?

Comment 3

12 years ago

*** This bug has been marked as a duplicate of 260174 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.