download manager shows negative file size for files larger than 2 GB (longint limit ?)

VERIFIED DUPLICATE of bug 184452

Status

()

Toolkit
Downloads API
VERIFIED DUPLICATE of bug 184452
13 years ago
10 years ago

People

(Reporter: tachyon.eagle, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.7) Gecko/20050414
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.7) Gecko/20050414

download manager shows negative file size for files larger than 2 GB  (longint
limit ?)
 -  in this case I downloaded from http source which doesn't give exact file
length ... the download length is unknown , so download manager increments
downloaded bytes as it gets them, but then (I couldn't realized an exact point
cause of line speed being a few MB/s) numbers became negative ... this happened
to me with DVD iso slightly larger than 2 GB ... which leads to be think that
there is 31 bit limit for filesizes. (at least from unknown sources)
 - I can reproduce this in Mozzila 1.7.7 and Firefox 1.0.3 (both @ Windows XP
platform)
 - however file finishes download and data seems valid

Reproducible: Always

Steps to Reproduce:
1.download file larger than 2 GB from non-resume-able source site
2.watch the filesize during download
3.

Actual Results:  
download manager shows negative file size after 2GB of data has been downloaded

Expected Results:  
if it's in variable limit, then it should have at least 64 bit for file sizes
and therefore show positive file sizes , however file finishes download and data
seems valid

the bug appears to be present in mozzila and firefox so I beleive it can be
present in software which shares source code with these

*** This bug has been marked as a duplicate of 184452 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Updated

13 years ago
Status: RESOLVED → VERIFIED
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.