Crash when opening popup window -> View Image with onunload="window.close()"

VERIFIED WORKSFORME

Status

()

--
critical
VERIFIED WORKSFORME
14 years ago
13 years ago

People

(Reporter: martijn.martijn, Unassigned)

Tracking

({crash, testcase})

Trunk
x86
Windows XP
crash, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(4 attachments, 1 obsolete attachment)

(Reporter)

Description

14 years ago
To reproduce, click on one of the photos, a popup window should appear.
Right click and then choose "View Image".
The window closes, because of the onunload="window.close()" script, but shortly
afterwards Firefox crashes.

Mozilla doesn't seem to be affected somehow.
I'll attach a testcase.
(Reporter)

Comment 1

14 years ago
Created attachment 183199 [details]
image for testcase
(Reporter)

Comment 2

14 years ago
Created attachment 183200 [details]
File that is opened in new window
(Reporter)

Comment 3

14 years ago
Created attachment 183201 [details]
Testcase
(Reporter)

Comment 4

14 years ago
Created attachment 183202 [details]
Testcase
Attachment #183201 - Attachment is obsolete: true
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050509
Firefox/1.0+ 2005050922

WFM, no crash , the window just closes
both in testcase as url
(Reporter)

Comment 6

14 years ago
Created attachment 183203 [details]
Backtrace from Firefox debug build

Sigh, the testcase still won't crash, because of a wrongly linked image in
"File that is opened in new window".
If it is really needed, I'll create new attachments, but I think the crash
condition is pretty self explanatory.
For me this is crashing on me every time, and I've also tried it with a clean
profile.
fwiw, I think I managed to trigger this on a pre-bfcache mozilla build too, so
this doesn't look like a recent regression.  :(

Updated

14 years ago
Keywords: crash
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050527
Firefox/1.0+ ID:2005052711

Martijn, have you tried a non-debug build
I tried a new fresh installation/new created profile and it just won't crash
(Reporter)

Comment 9

14 years ago
Well, it doesn't crash now also in my latest nightly builds.
Fwiw, it does crash with a 2005-05-19 build, but not anymore with a 2005-05-21
build.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME

Comment 10

13 years ago
Verified WFM using Win FF 1.5.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.