If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Closing last window left open in firefox when downloading creates unneeded alert.

RESOLVED WORKSFORME

Status

()

Toolkit
Downloads API
--
minor
RESOLVED WORKSFORME
13 years ago
9 years ago

People

(Reporter: Chris, Unassigned)

Tracking

({pp})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3

When you start to download a file, and only one window is left open, and you
close it, it displays something like "Are you sure you want to exit Firefox and
cancel all downloads?" when on a mac, you can close all the windows of a program
and still have firefox open. This may confuse some, because closing all the
windows of  firefox on a mac will NOT cancel all the downloads. This will
probably causes the user to click cancel, keep the window open, and leave it
open to keep the download is going, when you really don't need to. If the user
chooses the "Cancel all downloads" button it doesn't really cancel them, and
will keep downloading them in the background, with no firefox windows open. This
probably does not apply to other OSs.

Reproducible: Always

Steps to Reproduce:
1. Download any file that will take some time to download, so you can complete
the rest of the steps.
2. Close all windows, except for one.
3. Close the last window. A message will appear saying if you want to quit and
cancel the download.
4. Click the "Cancel all downloads" button
5. Go to the "Tools" menu and choose "Downloads"

Actual Results:  
The file being downloaded was not canceled, it was still loading.

Expected Results:  
Not shown a message to cancel it when the last window was closed. It should have
shown it when the user chose "Quit Frefox" from the Firefox menu.

Probably only applies to Mac OS.
(Reporter)

Updated

13 years ago
Summary: When downloading, and only one window left open in firefox → Closing last window left open in firefox when downloading creates unneeded alert.
(Reporter)

Updated

13 years ago
Keywords: pp

Comment 1

12 years ago
Exact text of error message reads "If you quit now, 1 download will be canceled. Are you sure you want to 
quit?"

Comment 2

10 years ago
Just checked this in Firefox 2.0.0.4, and this bug no longer seems to occur; suggest closing.

Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-GB; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4 ID:2007051502
Closing WFM per #2.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.