Horizontal page jumping lessens the quality of user experience

RESOLVED DUPLICATE of bug 72540

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 72540
14 years ago
14 years ago

People

(Reporter: pirkka, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.7) Gecko/20050414 Firefox/1.0.3 StumbleUpon/1.9995
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.7) Gecko/20050414 Firefox/1.0.3 StumbleUpon/1.9995

The scrollbar on the right only appears on long pages, causing sites with a
horizontally centered layout to "jump" from right to left as the page is rendered. 

The problem is underlined on sites that use the same layout on all of their
pages, causing the layout to visibly jump from left to right or vice versa, all
depending on the length of each browsed page.

I understand that technically Firefox is "saving" some pixels by not displaying
the "unneeded" scroll bar, but many users find the page jumping irritating. Use
of horizontally centered layouts is widespread today thanks to ever widening
displays.

Reproducible: Always

Steps to Reproduce:
Method one:

1. Load any long, slowly loading page with a horizontally centered layout.
2. Observe the web page jumping from right to left as the scroll bar appears, as
the page is rendered.

Mehtod two:

1. Load up the url http://www.google.com
2. Grab the lower-right corner of your browser window with the mouse pointer
3. Drag the corner up and down so that the scroll bar appears and disappears
4. OBSERVE the Google page layout jumping from left to right

Actual Results:  
Page layout is jumping horizontally.

Expected Results:  
Software should display a disabled vertical scroll bar on non scrollable pages
as well to keep the layout from jumping around.

Same logic does not apply to horizontal scrolling. No disabled horizontal scroll
bar please as that would truly be a waste of screen space!

I love Firefox but Internet Explorer did this thing right. I don't know about
Netscape and Opera.

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 72540 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.