Background image style aplied to the window element break painting

RESOLVED WONTFIX

Status

Core Graveyard
GFX
--
major
RESOLVED WONTFIX
13 years ago
4 years ago

People

(Reporter: Anders Conbere, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050428 Firefox/1.0.3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050428 Firefox/1.0.3

When the window element is assigned the background: value of a png file. The
browser to draw all elements and is generaly laggy and broken. This apears to
only be an issue with chrome, any content with this style works fine.

Reproducible: Always

Steps to Reproduce:
<described at webpage>

Actual Results:  
Browser elements fail to paint.

Expected Results:  
Theoreticaly the browser should display the the window elements with the png
background with little or no trouble.
(Reporter)

Updated

13 years ago
Version: unspecified → Trunk

Comment 1

13 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050511
Firefox/1.0+

Wow, that was seriously messed up.  On win32, this not only causes the things
specified in this report, but also makes FF ignore the screenspace assigned to
it and draw overtop the Windows taskbar.  FF stopped responding and had to be
closed from the task manager (I could have alt+f4ed maybe, but I didn't try
that).  I have a screencap of the effect on my system if it is needed.  Is this
possibly a regression from a recent check-in?  Changed OS to All.  Anybody know
which product/component this belongs in, because I am pretty sure it isn't
Firefox/General.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: clean-report
OS: Linux → All
Whiteboard: regression?

Comment 2

13 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050511

I confirm this happening on Seamonkey trunk as well.  Per kbrosnan's suggestion,
I am moving this to Core:GFX.
Component: General → GFX
Product: Firefox → Core

Updated

13 years ago
Assignee: nobody → general
QA Contact: general → ian
(Reporter)

Updated

13 years ago
Severity: normal → major
Someone needs to isolate the regression window

Comment 4

13 years ago
Builds from 04/01 (and possibly before, but later than 3/1) - 04/14 (to
somewhere between 04/14 and 05/01) crash instead. Same testcase. (TB5769204Y,
TB5769194G).

So far, i'm able to reproduce this all the way back to 02/01.

Comment 5

13 years ago
I've tested builds (jumping back, several weeks at a time) all the way to
2004-11-10. They're all broken with the testcase, in similar ways. (High CPU
Use, Hanging, Crashing, Missing Elements, etc.) I'm not sure when this broke,
but its either awhile ago, or something went weird during my testing.
(Firefox-Trunk/WinXP Pro)
(Reporter)

Comment 6

13 years ago
I just got done testing this with a .gif background

http://www.bytecave.net/anders/test_background.gif

and the same effects are observed as resutl I've changed the title of the bug to
"image styles".
Summary: .png style elements aplied to the window element breaks painting → Background image style aplied to the window element break painting
(Reporter)

Comment 7

13 years ago
And due to my own lack of foresight,

the same is again true for .jpg files.

http://www.bytecave.net/anders/test_background.jpg
(Reporter)

Comment 8

13 years ago
I've been made aware of a work around for this bug.

By simply applying a background color to the window element along with an image,
the browser behaves normaly.

an example userChrome entry is as follows

window{ background: #000000 url("test_background.png") fixed top !important; }

Though I still feel the browser should be able to handle the style without this
workaround, at least it can easily be bypassed.

Comment 9

13 years ago
there's no regression here.  in fact, setting a background seems to trigger the
transparent XUL code, which (until recently) was hosed, so older builds just
blow up completely (or at least do /really/ strange things).

Also (from the URL), to reproduce this bug, add this to your userChrome.css:

window{ background: url("test_background.png") fixed top !important; }
(test_background.png can be any image)
Whiteboard: regression?

Comment 10

13 years ago
(In reply to comment #9)
> there's no regression here.  in fact, setting a background seems to trigger the
> transparent XUL code, which (until recently) was hosed, so older builds just
> blow up completely (or at least do /really/ strange things).
> 
> Also (from the URL), to reproduce this bug, add this to your userChrome.css:
> 
> window{ background: url("test_background.png") fixed top !important; }
> (test_background.png can be any image)

According to the reporter, it only occurs on Trunk builds, and not on milestone
builds, so that would lead me to believe that somewhere something was broken
that wasn't broken when 1.0 branched.
Product: Core → Core Graveyard
This bug has been buried in the graveyard and has not been updated in over 5 years. It is probably safe to assume that it will never be fixed, so resolving as WONTFIX.

[Mass-change filter: graveyard-wontfix-2014-09-24]
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.